This Bugzilla instance is a read-only archive of historic NetBeans bug reports. To report a bug in NetBeans please follow the project's instructions for reporting issues.

Bug 189930 - Custom code folding doesn't work in Groovy editor
Summary: Custom code folding doesn't work in Groovy editor
Status: RESOLVED DUPLICATE of bug 190052
Alias: None
Product: groovy
Classification: Unclassified
Component: Editor (show other bugs)
Version: 6.x
Hardware: PC Windows XP
: P3 normal (vote)
Assignee: Martin Janicek
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-08-27 00:15 UTC by akochnev
Modified: 2012-03-15 16:22 UTC (History)
0 users

See Also:
Issue Type: DEFECT
Exception Reporter:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description akochnev 2010-08-27 00:15:05 UTC
// <editor-fold defaultstate="collapsed" desc="Setup Methods">
    void someMethod() {
        // do something
    }
// </editor-fold>

The custom code fold above does not work as expected in the Groovy editor. Copying and pasting the same snippet into a java editor makes the snippet collapse as expected. 

Note that the standard folding works in Groovy (e.g. to fold method body, comments, annotation).
Comment 1 Martin Janicek 2011-12-02 13:29:17 UTC
Still valid issue --> TM = 7.2
Comment 2 Martin Janicek 2012-03-15 16:22:07 UTC

*** This bug has been marked as a duplicate of bug 190052 ***