This Bugzilla instance is a read-only archive of historic NetBeans bug reports. To report a bug in NetBeans please follow the project's instructions for reporting issues.

Bug 190503 - NB needs a workspace profile feature
Summary: NB needs a workspace profile feature
Status: RESOLVED DUPLICATE of bug 151920
Alias: None
Product: projects
Classification: Unclassified
Component: Generic Infrastructure (show other bugs)
Version: 6.x
Hardware: PC Windows Vista
: P3 normal (vote)
Assignee: Jesse Glick
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-09-22 03:07 UTC by kitfox
Modified: 2011-05-25 08:07 UTC (History)
0 users

See Also:
Issue Type: ENHANCEMENT
Exception Reporter:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description kitfox 2010-09-22 03:07:40 UTC
I'm a long time user of NetBeans and like quite a lot of what the platform has to offer.  However, as I continue to use it I'm finding that my Project window is acquiring a very long list of mounted projects.  This is because I develop for a lot of different clients, and each client usually has multiple jars they need work on.  Add open source libraries and my own personal projects to that and my Projects window is an overlapping hard-to-navigate mess.  It also gives me long waits as NB scans 40+ projects every time it loads.

NB needs a workspace feature that would save a group of settings such as which projects are open and which files are shown in the edit pane.  Then I could set up different workspaces for each of the different sorts of projects I want to work on.  When I want to work for Company1 I can open Company1's workspace and see only the relevant projects.  When I want to do work for Company2, I can switch to that workspace - all the Company1 projects will close and Company2's will open.
Comment 1 Marian Mirilovic 2011-05-25 08:07:41 UTC
There is a Project Group feature, which defines group of opened projects ...

*** This bug has been marked as a duplicate of bug 151920 ***