This Bugzilla instance is a read-only archive of historic NetBeans bug reports. To report a bug in NetBeans please follow the project's instructions for reporting issues.

Bug 191187 - Code completion for NamedQueries
Summary: Code completion for NamedQueries
Status: RESOLVED FIXED
Alias: None
Product: javaee
Classification: Unclassified
Component: Persistence (show other bugs)
Version: 7.0
Hardware: All All
: P3 normal with 1 vote (vote)
Assignee: Sergey Petrov
URL:
Keywords:
: 201852 (view as bug list)
Depends on:
Blocks:
 
Reported: 2010-10-20 17:30 UTC by arungupta
Modified: 2012-03-03 11:32 UTC (History)
1 user (show)

See Also:
Issue Type: ENHANCEMENT
Exception Reporter:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description arungupta 2010-10-20 17:30:11 UTC
Please provide code completion for NamedQueries within createNamedQuery(...), such as hitting Ctrl+Space after "find" will show all the queries starting with that string.

emf.createEntityManager().createNamedQuery("Manufacturer.find")
Comment 1 Sergey Petrov 2012-02-01 15:29:54 UTC
*** Bug 201852 has been marked as a duplicate of this bug. ***
Comment 2 Geertjan Wielenga 2012-02-14 11:05:14 UTC
I agree, this would be great.
Comment 3 Sergey Petrov 2012-03-02 13:00:42 UTC
http://hg.netbeans.org/web-main/rev/204151b72e83 implemented
Comment 5 Quality Engineering 2012-03-03 11:32:59 UTC
Integrated into 'main-golden', will be available in build *201203030400* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/204151b72e83
User: Sergey B. Petrov <sj-nb@netbeans.org>
Log: #191187 cc for nq names in createnamedquery