This Bugzilla instance is a read-only archive of historic NetBeans bug reports. To report a bug in NetBeans please follow the project's instructions for reporting issues.

Bug 191206 - NullPointerException at org.netbeans.modules.form.layoutsupport.griddesigner.AnimationLayer.createContainerImage
Summary: NullPointerException at org.netbeans.modules.form.layoutsupport.griddesigner....
Status: RESOLVED FIXED
Alias: None
Product: guibuilder
Classification: Unclassified
Component: Code (show other bugs)
Version: 7.0
Hardware: All All
: P3 normal (vote)
Assignee: issues@guibuilder
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-10-21 09:22 UTC by Exceptions Reporter
Modified: 2010-11-12 08:20 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
Exception Reporter: 172938


Attachments
stacktrace (4.96 KB, text/plain)
2010-10-21 09:22 UTC, Exceptions Reporter
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Exceptions Reporter 2010-10-21 09:22:33 UTC
Build: NetBeans IDE 7.0 M2 (Build 201010151251)
VM: Java HotSpot(TM) Client VM, 16.3-b01, Java(TM) SE Runtime Environment, 1.6.0_20-b02
OS: Windows 7

User Comments:
AlyonaStashkova: Moved button to another cell within GridBag Customizer

GUEST: GridBagLayout > Change Panel Anchor to PageStart

AlyonaStashkova: Invoked GridBag Customizer, selected the table, moved the upper border down (the table did not resize), moved the bottom border up (the table did not resize), got an exeption

GUEST: GridBagLayout Customizer Dialog -> Chang Fill Property to Fill Horizontal

AlyonaStashkova: tried to expand button within GridBad to occupy more than one cell




Stacktrace: 
java.lang.NullPointerException
   at org.netbeans.modules.form.layoutsupport.griddesigner.AnimationLayer.createContainerImage(AnimationLayer.java:185)
   at org.netbeans.modules.form.layoutsupport.griddesigner.AnimationLayer.animate(AnimationLayer.java:166)
   at org.netbeans.modules.form.layoutsupport.griddesigner.GlassPane$GridActionWrapper.actionPerformed(GlassPane.java:1306)
   at org.netbeans.modules.form.layoutsupport.griddesigner.GlassPane.performAction(GlassPane.java:938)
   at org.netbeans.modules.form.layoutsupport.griddesigner.GlassPane.updateLayout(GlassPane.java:216)
   at org.netbeans.modules.form.layoutsupport.griddesigner.GridDesigner$5$1.run(GridDesigner.java:378)
Comment 1 Exceptions Reporter 2010-10-21 09:22:38 UTC
Created attachment 102539 [details]
stacktrace
Comment 2 Jan Stola 2010-11-12 08:18:08 UTC
I am able to reproduce this exception in NetBeans 7.0 M2 using the following steps:

1. Create JFrame.
2. Set frame's layout to GridBagLayout.
3. Add JButton.
4. Invoke Customize Layout on the frame.
5. Select the button in the customizer.
6. Close the customizer.
7. Open the customizer again.
8. Move the button into another cell
   => exception is thrown.
Comment 3 Jan Stola 2010-11-12 08:20:08 UTC
The same steps performed in the latest development build no longer lead to the
exception. The exception was caused by customizer's listener that was not
unregistered when the customizer was closed. This was fixed in
http://hg.netbeans.org/core-main/rev/10b7a030f4ef