This Bugzilla instance is a read-only archive of historic NetBeans bug reports. To report a bug in NetBeans please follow the project's instructions for reporting issues.

Bug 191217 - AssertionError: See bug 187004: project must not be null for projectDir="D:\env\products\dm\install\gemconnect"
Summary: AssertionError: See bug 187004: project must not be null for projectDir="D:\...
Status: RESOLVED DUPLICATE of bug 187004
Alias: None
Product: java
Classification: Unclassified
Component: JUnit (show other bugs)
Version: 7.0
Hardware: All All
: P3 normal with 2 votes (vote)
Assignee: Theofanis Oikonomou
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-10-21 13:29 UTC by lolo_101
Modified: 2011-11-14 18:46 UTC (History)
6 users (show)

See Also:
Issue Type: DEFECT
Exception Reporter: 172685


Attachments
stacktrace (725 bytes, text/plain)
2010-10-21 13:29 UTC, lolo_101
Details
stacktrace (717 bytes, text/plain)
2010-12-24 07:42 UTC, tkellerer
Details
stacktrace (717 bytes, text/plain)
2011-01-13 21:42 UTC, Exceptions Reporter
Details
stacktrace (699 bytes, text/plain)
2011-03-07 07:34 UTC, michbarsinai
Details
stacktrace (692 bytes, text/plain)
2011-03-07 07:37 UTC, michbarsinai
Details
stacktrace (692 bytes, text/plain)
2011-03-31 11:10 UTC, michbarsinai
Details

Note You need to log in before you can comment on or make changes to this bug.
Description lolo_101 2010-10-21 13:29:02 UTC
Build: NetBeans IDE 7.0 M2 (Build 201010151251)
VM: Java HotSpot(TM) Client VM, 17.1-b03, Java(TM) SE Runtime Environment, 1.6.0_22-b04
OS: Windows XP

User Comments:
Lolo_101: I think this is a long running bug...

Lolo_101: Tried to test a project




Stacktrace: 
java.lang.AssertionError: See bug 187004:  project must not be null for projectDir="D:\env\products\dm\install\gemconnect"
   at org.netbeans.modules.junit.output.JUnitAntLogger.getOutputReader(JUnitAntLogger.java:398)
   at org.netbeans.modules.junit.output.JUnitAntLogger.buildFinished(JUnitAntLogger.java:352)
   at org.apache.tools.ant.module.bridge.impl.NbBuildLogger.buildFinished(NbBuildLogger.java:410)
   at org.apache.tools.ant.Project.fireBuildFinished(Project.java:2091)
   at org.apache.tools.ant.module.bridge.impl.BridgeImpl.run(BridgeImpl.java:291)
   at org.apache.tools.ant.module.run.TargetExecutor.run(TargetExecutor.java:539)
Comment 1 lolo_101 2010-10-21 13:29:08 UTC
Created attachment 102544 [details]
stacktrace
Comment 2 lolo_101 2010-10-22 13:54:25 UTC
Is it because the working dir is not in the project's sourcepath ?
Comment 3 lolo_101 2010-10-22 14:00:44 UTC
BINGO !
If I add the working dir in the sourcepath, the exception doesn't pops up anymore.
So that's a workaround but I believe this should not be mandatory to have the working dir in the sourcepath.
Comment 4 tkellerer 2010-12-24 07:42:33 UTC
Created attachment 104471 [details]
stacktrace

Running a JUnit test. Note that the working dir has NOT been set in the project configuration!
Comment 5 Exceptions Reporter 2011-01-13 21:42:14 UTC
Created attachment 104976 [details]
stacktrace

running a Junit test
(I replaced the actual directory reported to .....)
Comment 6 tkellerer 2011-01-14 18:09:53 UTC
Why is this still P3?

Due to this bug, the JUnit support is totally broken...
Comment 7 michbarsinai 2011-03-07 07:34:39 UTC
Created attachment 106781 [details]
stacktrace

Tested a project (right-clicked the project in the "Projects" pane, selected "test" from the popup menu)
Comment 8 michbarsinai 2011-03-07 07:37:23 UTC
Created attachment 106782 [details]
stacktrace

Same as last report, but now, the project dir actually exist.
Comment 9 michbarsinai 2011-03-31 11:10:00 UTC
Created attachment 107402 [details]
stacktrace

While trying to run a JUnit test
Comment 10 Jesse Glick 2011-11-14 18:46:54 UTC

*** This bug has been marked as a duplicate of bug 187004 ***