This Bugzilla instance is a read-only archive of historic NetBeans bug reports. To report a bug in NetBeans please follow the project's instructions for reporting issues.

Bug 191984 - Tab indentation does not print
Summary: Tab indentation does not print
Status: RESOLVED WONTFIX
Alias: None
Product: editor
Classification: Unclassified
Component: Painting & Printing (show other bugs)
Version: 6.x
Hardware: PC Windows Vista
: P3 normal with 3 votes (vote)
Assignee: Miloslav Metelka
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-11-15 22:28 UTC by ritty
Modified: 2012-11-01 09:07 UTC (History)
1 user (show)

See Also:
Issue Type: ENHANCEMENT
Exception Reporter:


Attachments
Screen captures of editor and print preview (39.62 KB, image/gif)
2010-11-15 22:28 UTC, ritty
Details

Note You need to log in before you can comment on or make changes to this bug.
Description ritty 2010-11-15 22:28:14 UTC
Created attachment 102988 [details]
Screen captures of editor and print preview

Code is indented by tabs, but printout and print preview does not show these tabs, everything is instead aligned to the left. If lines are indented via spaces instead of tabs it looks OK.

I have tried uninstalling and reinstalling as well as using a different font.
Comment 1 Miloslav Metelka 2011-10-07 10:20:08 UTC
Reproducible in NB 7.1 Beta.
Comment 2 undead 2011-12-25 14:36:37 UTC
hey.. is there any news about this enhancement?
Comment 3 tgp1994 2012-08-16 00:42:50 UTC
This applies to 7.2 as well. A workaround mentioned was to enable converting tabs to spaces in the editor section of the preferences, then highlight an entire document of code, press Tab, then Shift tab. The print window will then show your document more or less like it should.

It would be nice to see some attention on this bug though... it seems to be approaching it two year anniversary of being "new".
Comment 4 David Strupl 2012-11-01 09:07:52 UTC
If someone feels really strongly about this please provide patches. Closing as wont fix.