This Bugzilla instance is a read-only archive of historic NetBeans bug reports. To report a bug in NetBeans please follow the project's instructions for reporting issues.

Bug 192010 - Can not edit program run environment on Ubuntu 10.10
Summary: Can not edit program run environment on Ubuntu 10.10
Status: RESOLVED DUPLICATE of bug 192390
Alias: None
Product: cnd
Classification: Unclassified
Component: Project (show other bugs)
Version: 7.0
Hardware: PC Linux
: P3 normal (vote)
Assignee: Thomas Preisler
: 191987 (view as bug list)
Depends on:
Reported: 2010-11-16 15:08 UTC by Vladimir Kvashin
Modified: 2010-12-03 18:16 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
Exception Reporter:


Note You need to log in before you can comment on or make changes to this bug.
Description Vladimir Kvashin 2010-11-16 15:08:18 UTC
Here's a citation from cnd forum:

In the properties "environment variable" dialog, clicking "add" adds a blank line. but i can't change the values of this blank line - click, double click, space, enter, typing text ... nothing has any effect. does anyone know how to change the value. i'm on 6.8 (and just tried 6.9 as well)

Running on ubuntu 10.10, amd-64
java version "1.6.0_20"
OpenJDK Runtime Environment (IcedTea6 1.9.1) (6b20-1.9.1-1ubuntu3)
OpenJDK 64-Bit Server VM (build 17.0-b16, mixed mode)
Comment 1 Thomas Preisler 2010-11-18 00:23:58 UTC
Cannot verify this. Tried Ubuntu 9.10 and JDK 1.6.0_15 but don't think the difference is the issue. The Environment dialog is however not very well designed though. You need to click Add to get a blank entry in the table and then you need to click in the fields to enter values. This is not very intuitive. The code is very old. Probably some of the oldest code in CND and need to be redesigned. Will close this bug as a dup of 192081

*** This bug has been marked as a duplicate of bug 192081 ***
Comment 2 Thomas Preisler 2010-11-18 00:33:50 UTC
*** Bug 191987 has been marked as a duplicate of this bug. ***
Comment 3 lytles 2010-11-18 01:23:05 UTC
you may or may not like the design. i don't really care about that. but this is clearly *not* a design issue. it's a plain old-fashioned bug. it might get fixed if you decide to do a redesign. or it might not, eg, if you reused your "edit values" code. this is not a duplicate - nothing in this bug report (or in the one that i entered that was marked as a dup of this one) complains about the design

Comment 4 Vladimir Kvashin 2010-11-18 11:46:14 UTC
I was able to reproduce it on Ubintu 10.10 with OpenJDK 1.6; 
and it didn't reproduced on other Ubuntu systems (don't remember exactly which ones I tried)
Comment 5 Thomas Preisler 2010-11-18 23:12:32 UTC
ok, will look at it....
Comment 6 Marian Mirilovic 2010-11-24 13:53:27 UTC
I think this is the same problem as described in issue 192390

*** This bug has been marked as a duplicate of bug 192390 ***
Comment 7 lytles 2010-11-24 16:12:25 UTC
it might be that this bug report and 192390 share an underlying cause, but it's  not a duplicate. 192390 is newer and is filed against refactoring (which this bug has nothing to do with). this bug describes a specific broken behavior, and it's important that it remain open to track that behavior and to provide a workaround*. i don't know enough of the inner workings of netbeans to hazard a guess as to whether your assumption that the underlying cause is the same is correct

* -- actually the workaround was provided in 191987, which was marked as a duplicate of this bug (in spite of being older and having a workaround...)

workaround (from 191987):
add a <variable> to the <environment> section of

          <variable name="LD_LIBRARY_PATH" value="/opt/local/lib"/>
Comment 8 Jan Lahoda 2010-11-26 15:13:46 UTC
I think the root cause for this bug and bug #192390 is the same - broken default cell editors for JTable in a specific JDK. Please see:
for details.
Comment 9 Thomas Preisler 2010-12-03 18:16:48 UTC
There are several work-arounds (some not very good though):

1) use a working JDK
2) hand-edit xml file as describe in #7

I think closing it as a dup of 192390 is correct. It is the same root cause. The information in this IZ is not lost because it is closed as a dup so not sure what the concern is.

*** This bug has been marked as a duplicate of bug 192390 ***