This Bugzilla instance is a read-only archive of historic NetBeans bug reports. To report a bug in NetBeans please follow the project's instructions for reporting issues.

Bug 193361 - Netbeans "Find in Projects" cannot be aborted
Summary: Netbeans "Find in Projects" cannot be aborted
Status: RESOLVED FIXED
Alias: None
Product: utilities
Classification: Unclassified
Component: Search (show other bugs)
Version: 7.1
Hardware: PC Windows XP
: P3 normal (vote)
Assignee: Jaroslav Havlin
URL:
Keywords: API_REVIEW_FAST
: 205079 (view as bug list)
Depends on:
Blocks:
 
Reported: 2010-12-14 10:16 UTC by karamba84
Modified: 2011-11-14 13:49 UTC (History)
4 users (show)

See Also:
Issue Type: DEFECT
Exception Reporter:


Attachments
Patch - updated API, its use in subclass, tests (17.64 KB, patch)
2011-08-23 15:20 UTC, Jaroslav Havlin
Details | Diff
Patch - updated API, its use in subclass, tests (17.66 KB, patch)
2011-08-26 08:56 UTC, Jaroslav Havlin
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description karamba84 2010-12-14 10:16:51 UTC
I have a tool which creates pretty big log files (about 1gb and more).
I searched for a keyword via "Edit"->"Find in Projects"->"Open Projects" and entered the keyword.

I forgot that i have a 1gb logfile in the project dir which has been also searched. It was not possible to abort the search. 

Reproduce:
1) Create a new Project
2) Put a big big text file into this project
3) search for something and try to hit abort search
Comment 1 Jaroslav Havlin 2011-08-23 15:20:29 UTC
Created attachment 110161 [details]
Patch - updated API, its use in subclass, tests
Comment 2 Jaroslav Havlin 2011-08-23 15:23:09 UTC
Please review updated API of org.openidex.search.SearchGroup.

One protected method (onStopSearch) was added. This method provides a way 
to customize stopping of a search task. It is helpful if the search task
contains some time-expensive sub-tasks that cannot access their parent's stop-flag.

The patch contains also changes in SpecialSearchGroup that uses newly added
method to stop searching in content of files, which can take a long time when the
files are big.
Comment 3 Jaroslav Tulach 2011-08-25 11:16:53 UTC
Y01 Missing @since on the new API method
Comment 4 Jaroslav Havlin 2011-08-26 08:56:50 UTC
Created attachment 110232 [details]
Patch - updated API, its use in subclass, tests

Updated patch - added @since annotation.
Comment 5 Jaroslav Havlin 2011-09-02 09:11:22 UTC
core-main/rev/56d7497d3654
Comment 6 Jesse Glick 2011-09-02 12:22:19 UTC
You need to set Target Milestone when closing any issue as FIXED.

By the way any test calling Thread.sleep, especially with such a short wait (10msec), is very likely to become @org.netbeans.junit.RandomlyFails sooner or later when it gets run on an overloaded continuous builder. You can use java.util.concurrent.Semaphore or the like to make sure threads have gotten to expected points.
Comment 7 Quality Engineering 2011-09-03 14:26:41 UTC
Integrated into 'main-golden', will be available in build *201109030600* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/56d7497d3654
User: Jaroslav Havlin <jhavlin@netbeans.org>
Log: #193361 - Find in Projects cannot be aborted
Comment 8 Jaroslav Havlin 2011-11-14 13:49:54 UTC
*** Bug 205079 has been marked as a duplicate of this bug. ***