This Bugzilla instance is a read-only archive of historic NetBeans bug reports. To report a bug in NetBeans please follow the project's instructions for reporting issues.

Bug 195114 - "JVM creation failed" happens at 2nd startup since 7.0 Beta
Summary: "JVM creation failed" happens at 2nd startup since 7.0 Beta
Status: RESOLVED DUPLICATE of bug 183941
Alias: None
Product: platform
Classification: Unclassified
Component: Launchers&CLI (show other bugs)
Version: 7.0
Hardware: PC Windows XP
: P2 normal with 1 vote (vote)
Assignee: Antonin Nebuzelsky
Keywords: RELNOTE
Depends on:
Reported: 2011-02-07 03:31 UTC by Masaki Katakai
Modified: 2011-06-01 16:35 UTC (History)
4 users (show)

See Also:
Issue Type: DEFECT
Exception Reporter:


Note You need to log in before you can comment on or make changes to this bug.
Description Masaki Katakai 2011-02-07 03:31:48 UTC
In NetBeans Japanese community mailing list, I got several
reports (at least 3 users) that NetBeans 7.0 Beta could not
start by "JVM creation failed". 

The first startup - just after installation, it succeeded. However,
after closing NetBeans once, NetBeans no longer start by the error.

They used the same machine for NetBeans 6.9 and NetBeans 7.0.
NetBeans 6.9 can start. But NetBeans 7.0 can not with the default settings.

One reporter kindly compared netbeans.conf - he says -J-XX:MaxPermSize=
part is different from 6.9 and it causes the error. When he used 6.9's value,
it works on NetBeans 7.0.

netbeans_default_options="-J-client -J-Xss2m -J-Xms32m -J-XX:PermSize=32m -J-XX:MaxPermSize=200m -J-Dapple.laf.useScreenMenuBar=true -J-Dsun.java2d.noddraw=true"

NetBeans Dev 201102030000:
netbeans_default_options="-J-client -J-Xss2m -J-Xms32m -J-XX:PermSize=32m -J-XX:MaxPermSize=384m -J-Dnetbeans.logger.console=true -J-ea -J-Dapple.laf.useScreenMenuBar=true -J-Dsun.java2d.noddraw=true"

I understand these are default values and usually users do not need to
modify it for their machines.

Any clue? Why it's different between 6.9 and 7.0?
Comment 1 Masaki Katakai 2011-02-07 03:47:48 UTC

  Product Version         = NetBeans IDE Dev (Build 201102030000) (#87dcb2d86d14)
  Operating System        = Windows XP version 5.1 running on x86
  Java; VM; Vendor        = 1.6.0_23; Java HotSpot(TM) Client VM 19.0-b09; Sun Microsystems Inc.
  Runtime                 = Java(TM) SE Runtime Environment 1.6.0_23-b05
  Java Home               = C:\Program Files\Java\jdk1.6.0_23\jre
  System Locale; Encoding = ja_JP (nb); MS932
Comment 2 Antonin Nebuzelsky 2011-03-10 21:17:55 UTC
The increase of -J-XX:MaxPermSize from 200m to 384m was introduced when fixing issue 190336.

It seems that in some cases it is not possible to allocate the increased amount of java process memory in the virtual address space.

Can you tell how much RAM these users have and if they are on 32-bit or 64-bit Java?

I guess we will need to adjust -J-XX:MaxPermSize based on user's RAM, e.g. 256m for <=2gb and 384 only for >2gb.
Comment 3 Marian Mirilovic 2011-03-10 21:36:26 UTC
(In reply to comment #2)
> I guess we will need to adjust -J-XX:MaxPermSize based on user's RAM, e.g. 256m
> for <=2gb and 384 only for >2gb.

Hold on Tonda, it's too risky to do such change in this period of release cycle. If we will do so, QE needs to retest all OSes and it will take us 4-6 weeks.

We can do :
- mention this in Release Notes for 7.0 + FAQ
- integrate change at the beginning of 7.0.1, when we plan to re-test it once again
Comment 4 Tomas Danek 2011-03-22 13:02:25 UTC
Tondo, will you start waiver process, to get this out of dashboard?
I've added comment so it won't be forgotten once release notes will be created.
Comment 5 scanti 2011-03-23 09:50:32 UTC
I have the same problem with my company RCP application based on 6.9.1 . It happens after I have updated some  modules. I have to restart it 2 or three times to see it working. I am Italian but I have a Windows Vista in Japanese
Comment 6 AlyonaStashkova 2011-04-03 15:21:57 UTC
Added to RNs (http://nbstaging.czech/community/releases/70/relnotes.html#known_issues-core), please review.
Comment 7 Tomas Danek 2011-04-04 07:01:12 UTC
Note is ok IMO, thanks.
(In reply to comment #6)
> Added to RNs
> (http://nbstaging.czech/community/releases/70/relnotes.html#known_issues-core),
> please review.
Comment 8 js-java 2011-04-06 15:29:00 UTC
Just for information: 

I have this issue on NetBeans 7.0 RC1 running on

Window 7 x64 using 32bit Java and 4 GB Ram. Using -J-Xmx256m or -J-Xmx512m as discussed in bug 183941 worked.

Editing netbeans.conf setting -J-XX:MaxPermSize=200m didn't help for me!
Comment 9 christianlerch 2011-05-09 16:36:20 UTC
I had the same problem with a new NetBeans 7.0 installation on a WinXP x86 32Bit, jdk 1.6.0_24-b07, with 6.9.1 already installed, and working fine.

Just adding  "-J-Xmx256m"  to the netbeans_default_options, and thus not releying on the default value solved the problem.

Comment 10 Antonin Nebuzelsky 2011-06-01 16:35:01 UTC

*** This bug has been marked as a duplicate of bug 183941 ***