This Bugzilla instance is a read-only archive of historic NetBeans bug reports. To report a bug in NetBeans please follow the project's instructions for reporting issues.

Bug 195633 - Code-completion popup appears too often for pom.xml
Summary: Code-completion popup appears too often for pom.xml
Status: RESOLVED WONTFIX
Alias: None
Product: xml
Classification: Unclassified
Component: Schema (show other bugs)
Version: 7.0
Hardware: PC Linux
: P3 normal with 2 votes (vote)
Assignee: Svata Dedic
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-02-17 23:56 UTC by pekarna
Modified: 2015-09-17 13:21 UTC (History)
0 users

See Also:
Issue Type: DEFECT
Exception Reporter:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description pekarna 2011-02-17 23:56:46 UTC
When editing pom.xml, the code completion menu appears way too often - almost on every key stroke.

STR:

1) Edit some pom.xml
2) Have a cursor somewhere between tags
3) Press enter - popup appears, press escape
4) Press space - popup appears, press escape
5) Press Ctrl+V - popup appears, press escape

etc etc.

I'd let it show only on Ctrl+space like with Java.
Comment 1 pekarna 2011-02-17 23:57:47 UTC
Latest nightly
Comment 2 Dusan Balek 2011-02-18 10:13:17 UTC
Code completion is invoked automatically by SchemaBasedCompletionProvider.

As a temporary workaround you can switch off "Auto Popup Completion Window" in Tools -> Options-> Editor -> Code Completion.

Reassigning to xml.schema.completion
Comment 3 Martin Balin 2015-09-17 13:21:24 UTC
Report from old NetBeans version. Due to code changes since it was reported likely not reproducible now. Feel free to reopen if happens in 8.0.2 or 8.1.