This Bugzilla instance is a read-only archive of historic NetBeans bug reports. To report a bug in NetBeans please follow the project's instructions for reporting issues.

Bug 196004 - Code move by mouse needs 2 undo actions to be undone
Summary: Code move by mouse needs 2 undo actions to be undone
Status: CLOSED DUPLICATE of bug 60560
Alias: None
Product: editor
Classification: Unclassified
Component: -- Other -- (show other bugs)
Version: 7.0
Hardware: All All
: P3 normal with 1 vote (vote)
Assignee: David Strupl
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-02-25 14:43 UTC by Jaromir Uhrik
Modified: 2011-02-28 10:20 UTC (History)
0 users

See Also:
Issue Type: DEFECT
Exception Reporter:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jaromir Uhrik 2011-02-25 14:43:23 UTC
Product Version: NetBeans IDE Dev (Build 201102250001)
Java: 1.6.0_23; Java HotSpot(TM) Client VM 19.0-b09
System: Windows XP version 5.1 running on x86; Cp1250; cs_CZ (nb)

Steps to reproduce:
-select a block of code in editor and drag it by mouse
-drop the code to some other place
-push Ctrl+Z to undo
-->>this action only copies the code to the original position but doesn't delete the copy. The undo action needs to be called once more to have the code in the original status.
Comment 1 David Strupl 2011-02-28 09:57:27 UTC

*** This bug has been marked as a duplicate of bug 60560 ***
Comment 2 Jaromir Uhrik 2011-02-28 10:20:40 UTC
Duplicate => Verified->Closed.