This Bugzilla instance is a read-only archive of historic NetBeans bug reports. To report a bug in NetBeans please follow the project's instructions for reporting issues.

Bug 19825 - right click xml text edit> beautify/indent
Summary: right click xml text edit> beautify/indent
Status: CLOSED DUPLICATE of bug 15749
Alias: None
Product: xml
Classification: Unclassified
Component: Text-Edit (show other bugs)
Version: 3.x
Hardware: PC Other
: P3 blocker (vote)
Assignee: _ pkuzel
URL:
Keywords:
Depends on: 18413
Blocks:
  Show dependency tree
 
Reported: 2002-01-28 10:56 UTC by Dennis Daniels
Modified: 2007-09-25 01:33 UTC (History)
0 users

See Also:
Issue Type: ENHANCEMENT
Exception Reporter:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Dennis Daniels 2002-01-28 10:56:09 UTC
a VERY nice enhancement:
right click on the edit window
option: beautify / auto indent for xml tags

clean out extraneous breaks
clean out white spaces in tags
Comment 1 _ pkuzel 2002-01-28 12:58:18 UTC
Thanks it is already filled.

Do you have idea for customization parameters? Every user has its own
opinion what if beauty formated XML (e.g. some users want every
attribute at a new line). So customizable formatter will be needed. If
so, please mention them in #15749.

Thanks a lot

*** This issue has been marked as a duplicate of 15749 ***
Comment 2 Quality Engineering 2003-07-02 08:36:20 UTC
Resolved for 3.4.x or earlier, no new info since then -> verify.
Comment 3 Quality Engineering 2003-07-02 08:39:11 UTC
Resolved for 3.4.x or earlier, no new info since then -> closing.