Bug 198451 - False modification reporting
Summary: False modification reporting
Status: RESOLVED FIXED
Alias: None
Product: versioncontrol
Classification: Unclassified
Component: Git (show other bugs)
Version: 7.0
Hardware: PC Windows 7 x64
: P3 normal with 2 votes (vote)
Assignee: Ondrej Vrabec
URL:
Keywords:
: 200465 203743 204795 207679 208776 212271 213844 (view as bug list)
Depends on: 208993
Blocks:
  Show dependency tree
 
Reported: 2011-05-09 11:10 UTC by ftaioli
Modified: 2014-09-18 15:04 UTC (History)
11 users (show)

See Also:
Issue Type: DEFECT
Exception Reporter:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description ftaioli 2011-05-09 11:10:39 UTC
Hi,

In a window 7 machine we have clone a git repository from a MAC machine sharing the folder

c:\dev\ > git clone file://path/to/shared/project/folder/on/mac clonedproject

The problem is netbeans reports all file as modified, opening files on diff show only two arrow at the start of the files.

But doing 

c:\dev\clonedproject > git status

correctly report "nothing to commint (working directory clean)"

Resetting the working tree from netbeans dosen't help.
Comment 1 Ondrej Vrabec 2011-05-09 11:37:09 UTC
Edit clonedproject\.git\config and add:
[core]
autocrlf = false

Does it help?
Comment 2 ftaioli 2011-05-09 13:29:51 UTC
(In reply to comment #1)
> Edit clonedproject\.git\config and add:
> [core]
> autocrlf = false
> 
> Does it help?

Simply adding autocrlf=false does not help but follow this tutorial
http://help.github.com/dealing-with-lineendings/
Resolved the problem (Or bypassed it!?)

I think netbeans must always report the same diffs of "git status"
Comment 3 Ondrej Vrabec 2011-05-09 14:35:58 UTC
> Simply adding autocrlf=false does not help but follow this tutorial
> http://help.github.com/dealing-with-lineendings/
> Resolved the problem (Or bypassed it!?)
So you actually set it to "true" ?

> I think netbeans must always report the same diffs of "git status"
It's a problem of the external JGit library we use, not NetBeans. I can only help to find a work-around (now you have one) but cannot fix this, sorry.
Comment 4 ftaioli 2011-05-09 14:40:54 UTC
Yes I set it to true and rechecked out the tree as described by the tutorial.
Comment 5 Ondrej Vrabec 2011-07-30 05:55:14 UTC
*** Bug 200465 has been marked as a duplicate of this bug. ***
Comment 6 akochnev 2011-08-01 15:50:39 UTC
@ovrabec - is there a corresponding bug in jgit's issue tracking that might give an indication of when it will be addressed in the upstream library ? 

It seems to me just saying "it's an upstream bug" is not sufficient - the IDE users are suffering from this , regardless of where the issue originates from.
Comment 7 hjr 2011-10-26 09:38:33 UTC
@akochnev: https://bugs.eclipse.org/bugs/show_bug.cgi?id=301775

I would like to have this fixed, too. This bug makes cross-platform development using Netbeans + git a nightmare.
Comment 8 Ondrej Vrabec 2011-11-07 21:38:25 UTC
*** Bug 204795 has been marked as a duplicate of this bug. ***
Comment 9 Marian Petras 2012-01-23 18:13:01 UTC
Ondřej, it seems there has been some essential progress on the side of JGit recently (see https://bugs.eclipse.org/bugs/show_bug.cgi?id=301775). Could you please re-evaluate it such that we get some chance that this annoying bug would be fixed?

I have also reopened this bug because I could not believe you had totally given up fixing it :-).
Comment 10 Ondrej Vrabec 2012-01-24 08:46:15 UTC
*** Bug 203743 has been marked as a duplicate of this bug. ***
Comment 11 Ondrej Vrabec 2012-01-24 12:36:57 UTC
*** Bug 207679 has been marked as a duplicate of this bug. ***
Comment 12 Ondrej Vrabec 2012-02-23 08:42:41 UTC
*** Bug 208776 has been marked as a duplicate of this bug. ***
Comment 13 Ondrej Vrabec 2012-02-24 11:22:59 UTC
If JGit releases 1.3 in time and the fix on their side helps, we could deliver the fix in a 7.1 patch.
Comment 14 Ondrej Vrabec 2012-03-06 09:27:16 UTC
fix: http://hg.netbeans.org/core-main/rev/14ed2114089d
Comment 15 Quality Engineering 2012-03-08 11:04:49 UTC
Integrated into 'main-golden', will be available in build *201203080400* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/14ed2114089d
User: Ondrej Vrabec <ovrabec@netbeans.org>
Log: #198451 - False modification reporting
Comment 16 Ondrej Vrabec 2012-03-12 09:45:26 UTC
fixed 14ed2114089d
Comment 17 Ondrej Vrabec 2012-05-10 10:11:06 UTC
*** Bug 212271 has been marked as a duplicate of this bug. ***
Comment 18 Ondrej Vrabec 2012-06-08 20:35:22 UTC
*** Bug 213844 has been marked as a duplicate of this bug. ***