This Bugzilla instance is a read-only archive of historic NetBeans bug reports. To report a bug in NetBeans please follow the project's instructions for reporting issues.

Bug 199205 - NullPointerException at org.netbeans.modules.debugger.jpda.projects.BreakpointAnnotationProvider.annotate
Summary: NullPointerException at org.netbeans.modules.debugger.jpda.projects.Breakpoin...
Status: RESOLVED FIXED
Alias: None
Product: apisupport
Classification: Unclassified
Component: Project (show other bugs)
Version: 7.1
Hardware: All All
: P2 normal (vote)
Assignee: Jesse Glick
URL:
Keywords:
: 199206 199285 (view as bug list)
Depends on:
Blocks: 196810
  Show dependency tree
 
Reported: 2011-06-06 17:00 UTC by Jesse Glick
Modified: 2012-10-11 12:08 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
Exception Reporter: 179205


Attachments
stacktrace (848 bytes, text/plain)
2011-06-06 17:00 UTC, Jesse Glick
Details
stacktrace (848 bytes, text/plain)
2011-06-06 17:21 UTC, Jesse Glick
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jesse Glick 2011-06-06 17:00:21 UTC
Build: NetBeans IDE Dev (Build 20110606-cec0d10d4352)
VM: Java HotSpot(TM) Client VM, 20.0-b11, Java(TM) SE Runtime Environment, 1.6.0_25-b06
OS: Linux

User Comments:
jglick: Just opened an XML layer.




Stacktrace: 
java.lang.NullPointerException
   at org.netbeans.modules.debugger.jpda.projects.BreakpointAnnotationProvider.annotate(BreakpointAnnotationProvider.java:108)
   at org.openide.text.CloneableEditorSupport.ensureAnnotationsLoaded(CloneableEditorSupport.java:406)
   at org.openide.text.CloneableEditor$DoInitialize$3.run(CloneableEditor.java:823)
   at org.openide.util.RequestProcessor$Task.run(RequestProcessor.java:1424)
   at org.openide.util.RequestProcessor$Processor.run(RequestProcessor.java:1968)
Comment 1 Jesse Glick 2011-06-06 17:00:25 UTC
Created attachment 108762 [details]
stacktrace
Comment 2 Jesse Glick 2011-06-06 17:19:48 UTC
Thrown consistently for me.
Comment 3 Jesse Glick 2011-06-06 17:21:03 UTC
Created attachment 108764 [details]
stacktrace
Comment 4 Martin Entlicher 2011-06-07 09:18:41 UTC
Lookup argument is null. And the Javadoc of AnnotationProvider.annotate() does not say that Lookup context can be null.
Someone probably created CloneableEditorSupport(Env env, Lookup l) with null "l".
Comment 5 Jesse Glick 2011-06-07 15:52:43 UTC
*** Bug 199206 has been marked as a duplicate of this bug. ***
Comment 6 Jesse Glick 2011-06-07 16:00:33 UTC
Constructor initialization order issue in LayerDataObject. But just started happening recently - why?
Comment 7 Jesse Glick 2011-06-07 16:06:05 UTC
447ad448a605 seems to have caused this: DataEditorSupport.create suddenly began assuming that DataObject.getLookup is complete, even though this helper method is often called in the object's constructor.
Comment 8 Jesse Glick 2011-06-07 16:12:00 UTC
core-main #b28d1ed6f766
Comment 9 Quality Engineering 2011-06-08 14:51:18 UTC
Integrated into 'main-golden'
Changeset: http://hg.netbeans.org/main-golden/rev/b28d1ed6f766
User: Jesse Glick <jglick@netbeans.org>
Log: #199205: NullPointerException at org.netbeans.modules.debugger.jpda.projects.BreakpointAnnotationProvider.annotate
Comment 10 Peter Nabbefeld 2011-06-17 08:34:06 UTC
There's another NPE, also related to editing layer files, while the stacktrace looks different. However, as the exception reporter still assigns reports to this issue, I cannot do anything else than to reopen this bug. Probably somebody from the NetBeans site administrators could fix this?
Comment 11 Jesse Glick 2011-06-20 21:03:58 UTC
If you believe you have come across a different bug, file it separately please. But be sure to actually use a fresh dev build, not merely an old build with a few updates from the dev UC (which will not generally include bug fixes):

	org.netbeans.modules.apisupport.project/1 [1.47 nbms-and-javadoc-7221-on-20110519]
Comment 12 Peter Nabbefeld 2011-06-21 06:14:29 UTC
(In reply to comment #11)
> If you believe you have come across a different bug, file it separately please.
> But be sure to actually use a fresh dev build, not merely an old build with a
> few updates from the dev UC (which will not generally include bug fixes):
> 
>     org.netbeans.modules.apisupport.project/1 [1.47
> nbms-and-javadoc-7221-on-20110519]

For what's an UC good, if it doesn't contain fixes???

The problem here seems to be, that a fix doesn't change the intended functionality of a module, so spec version isn't upgraded, while patch versions aren't supported for UC. UC will never work correctly (in the sense of distributing updates which are sufficient for having a fully functional IDE), if one cannot get the latest patches from it.
Comment 13 Peter Nabbefeld 2011-06-21 06:34:58 UTC
(In reply to comment #12)

Filed issue #199570 for UC.
Comment 14 David Strupl 2012-10-11 12:08:24 UTC
*** Bug 199285 has been marked as a duplicate of this bug. ***