This Bugzilla instance is a read-only archive of historic NetBeans bug reports. To report a bug in NetBeans please follow the project's instructions for reporting issues.

Bug 201814 - NullPointerException at org.netbeans.core.windows.view.EditorView$EditorAreaComponent$1.drop(EditorView.java:252)
Summary: NullPointerException at org.netbeans.core.windows.view.EditorView$EditorAreaC...
Status: RESOLVED DUPLICATE of bug 197559
Alias: None
Product: platform
Classification: Unclassified
Component: Window System (show other bugs)
Version: 6.x
Hardware: PC Windows XP
: P3 normal (vote)
Assignee: Stanislav Aubrecht
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-09-08 12:43 UTC by elena_regs
Modified: 2011-11-16 16:39 UTC (History)
0 users

See Also:
Issue Type: DEFECT
Exception Reporter:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description elena_regs 2011-09-08 12:43:39 UTC
I'm working on application build on top of the NetBeans platform.
The bug happens very rarely and randomly. No specific steps - when drag and drop an item from the palette you get the below exception. After that you are able to repeat the action and add the item successfully.

java.lang.NullPointerException
at org.netbeans.core.windows.view.EditorView$EditorAreaComponent$1.drop(EditorView.java:252)
at java.awt.dnd.DropTarget.drop(Unknown Source)
at sun.awt.dnd.SunDropTargetContextPeer.processDropMessage(Unknown Source)
at sun.awt.dnd.SunDropTargetContextPeer$EventDispatcher.dispatchDropEvent(Unknown Source)
at sun.awt.dnd.SunDropTargetContextPeer$EventDispatcher.dispatchEvent(Unknown Source)
at sun.awt.dnd.SunDropTargetEvent.dispatch(Unknown Source)
at java.awt.Component.dispatchEventImpl(Unknown Source)
at java.awt.Container.dispatchEventImpl(Unknown Source)
at java.awt.Component.dispatchEvent(Unknown Source)
at java.awt.LightweightDispatcher.retargetMouseEvent(Unknown Source)
at java.awt.LightweightDispatcher.processDropTargetEvent(Unknown Source)
at java.awt.LightweightDispatcher.dispatchEvent(Unknown Source)
at java.awt.Container.dispatchEventImpl(Unknown Source)
at java.awt.Window.dispatchEventImpl(Unknown Source)
at java.awt.Component.dispatchEvent(Unknown Source)
at java.awt.EventQueue.dispatchEventImpl(Unknown Source)
at java.awt.EventQueue.access$000(Unknown Source)
at java.awt.EventQueue$1.run(Unknown Source)
at java.awt.EventQueue$1.run(Unknown Source)
at java.security.AccessController.doPrivileged(Native Method)
at java.security.AccessControlContext$1.doIntersectionPrivilege(Unknown Source)
at java.security.AccessControlContext$1.doIntersectionPrivilege(Unknown Source)
at java.awt.EventQueue$2.run(Unknown Source)
at java.awt.EventQueue$2.run(Unknown Source)
at java.security.AccessController.doPrivileged(Native Method)
at java.security.AccessControlContext$1.doIntersectionPrivilege(Unknown Source)
at java.awt.EventQueue.dispatchEvent(Unknown Source)
at org.netbeans.core.TimableEventQueue.dispatchEvent(TimableEventQueue.java:137)
at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
at java.awt.EventDispatchThread.run(Unknown Source)
Comment 1 Stanislav Aubrecht 2011-09-12 09:38:10 UTC
please provide jdk and netbeans version info and reopen, thanks
Comment 2 elena_regs 2011-09-12 13:53:43 UTC
NetBeans Version was provided - 6.9.1
JRE v6.24
Comment 3 Stanislav Aubrecht 2011-09-12 13:57:04 UTC
i need also netbeans build number. please click menu 'help - about' and copy/paste the info from about window, thanks.

also, is this reproducible in netbeans 7.0 or in dev builds?
Comment 4 elena_regs 2011-09-12 14:25:47 UTC
201007282301

This bug happened a few times on a QA machine. I wasn't able to reproduce it on my dev machine. We don't use NetBeans 7 for now.
Comment 5 Stanislav Aubrecht 2011-09-12 14:29:27 UTC
should be fixed in issue #197559

*** This bug has been marked as a duplicate of bug 197559 ***