Bug 204741 - FXML code completion
Summary: FXML code completion
Status: RESOLVED FIXED
Alias: None
Product: javafx
Classification: Unclassified
Component: Editor (show other bugs)
Version: 7.1
Hardware: PC Other
: P2 normal with 2 votes (vote)
Assignee: Svata Dedic
URL:
Keywords: PLAN
: 202380 (view as bug list)
Depends on: 209819
Blocks: 199283
  Show dependency tree
 
Reported: 2011-11-07 09:26 UTC by Anton Chechel
Modified: 2012-08-03 07:42 UTC (History)
3 users (show)

See Also:
Issue Type: TASK
Exception Reporter:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Anton Chechel 2011-11-07 09:26:47 UTC

    
Comment 1 Anton Chechel 2011-11-07 09:35:39 UTC
*** Bug 202380 has been marked as a duplicate of this bug. ***
Comment 2 tremel 2012-01-27 13:06:44 UTC
I also have no code completion in FXML files in 7.1 final. The ide log shows this error even if I have a functioning internet connection:

> java.io.FileNotFoundException: http://javafx.com/fxml
> 	at sun.net.www.protocol.http.HttpURLConnection.getInputStream(HttpURLConnection.java:1610)
> 	at java.net.HttpURLConnection.getResponseCode(HttpURLConnection.java:468)
> 	at org.netbeans.modules.xml.retriever.impl.URLResourceRetriever.getInputStreamOfURL(URLResourceRetriever.java:171)
> Caused: java.io.FileNotFoundException: http://javafx.com/fxml
> 	at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
> 	at sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:57)
> 	at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:45)
> 	at java.lang.reflect.Constructor.newInstance(Constructor.java:525)
> 	at sun.net.www.protocol.http.HttpURLConnection$6.run(HttpURLConnection.java:1661)

Is it possible that the namespac-URI is tried for schema loading?
Comment 3 Svata Dedic 2012-08-03 07:42:00 UTC
Basic completion was implemented, connection of class tags with import should be implemented as part of the 'organize imports' task.