This Bugzilla instance is a read-only archive of historic NetBeans bug reports. To report a bug in NetBeans please follow the project's instructions for reporting issues.

Bug 205801 - REST: Customer Database on Spring (Java EE 5) is uncompilable
Summary: REST: Customer Database on Spring (Java EE 5) is uncompilable
Status: VERIFIED INVALID
Alias: None
Product: javaee
Classification: Unclassified
Component: Samples (show other bugs)
Version: 7.1
Hardware: PC Windows XP
: P3 normal (vote)
Assignee: Martin Janicek
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-12-01 19:22 UTC by Jiri Skrivanek
Modified: 2012-02-14 10:13 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
Exception Reporter:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jiri Skrivanek 2011-12-01 19:22:52 UTC
Product Version: NetBeans IDE 7.1 RC2 (Build 201111302200)
Java: 1.7.0_02; Java HotSpot(TM) Client VM 22.0-b10
System: Windows XP version 5.1 running on x86; Cp1250; en_US (nb)

Sample project REST: Customer Database on Spring (Java EE 5) is uncompilable. To reproduce:

- open new project wizard
- choose "Samples|Java Web Services|REST: Customer Database on Spring (Java EE 5)"
- click Next
- click Finish
- call Run on project node but compilation fails

D:\Development\builds\NB71\nbUserdir-20111201104029\CustomerDBSpring\CustomerDBSpring\src\java\customerdb\service\CustomerRESTFacade.java:68: error: incompatible types
    @Error("Please fix your project manually, for instructions see http://wiki.netbeans.org/SpringWithAopalliance")
  required: Annotation
  found:    Error
D:\Development\builds\NB71\nbUserdir-20111201104029\CustomerDBSpring\CustomerDBSpring\src\java\customerdb\service\DiscountCodeRESTFacade.java:68: error: incompatible types
    @Error("Please fix your project manually, for instructions see http://wiki.netbeans.org/SpringWithAopalliance")
  required: Annotation
  found:    Error
Comment 1 Martin Janicek 2012-02-07 16:05:29 UTC
Denis, could you give me advice here? Why are @Error annotations presented in CustomerRESTFacade and DiscountCodeRESTFacade?
Comment 2 Denis Anisimov 2012-02-07 16:09:11 UTC
Is it not obvious that one should go and see the 
http://wiki.netbeans.org/SpringWithAopalliance ?

This is by design. It will not be fixed.
This is not a bug.
Feel free to close it.
Comment 3 Martin Janicek 2012-02-07 16:13:01 UTC
Ah, sorry I was thinking that the message is a part of some kind of UI error. Now it's quite obvious ;]

Thanks for a quick response --> Closing as INVALID