Bug 206067 - SFTP wants to download remote .svn directories but fails on it.
Summary: SFTP wants to download remote .svn directories but fails on it.
Status: VERIFIED FIXED
Alias: None
Product: php
Classification: Unclassified
Component: FTP Support (show other bugs)
Version: 7.1
Hardware: All All
: P2 normal with 1 vote (vote)
Assignee: Tomas Mysik
URL:
Keywords: REGRESSION
Depends on:
Blocks:
 
Reported: 2011-12-07 10:10 UTC by Cobra_Fast
Modified: 2012-02-13 12:44 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
Exception Reporter:


Attachments
messages.log (220.06 KB, application/octet-stream)
2011-12-07 10:10 UTC, Cobra_Fast
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Cobra_Fast 2011-12-07 10:10:32 UTC
Created attachment 113913 [details]
messages.log

I just got the 7.1 RC2 and noticed something that doesn't seem right to me.

Looks like the updated SFTP client downloads hidden files, like .svn-directories from the remote server.

I'm using the PHP with remote sources feature with SVN on the server - not locally.
Now when I tell it to download files (e.g. after an update through svn on the server) it's downloading the .svn directories.
This wouldn't be so bad if it would work, but downloading those directories fails with an exception on certain files and downloading stopps (download is incomplete/not all files downloaded).

Error is: "Cannot lock read-only file C:\[...]\.svn\entries.new~", "A org.openide.util.RequestProcessor$SlowItem exception has occurred".

Is there an immediate solution or do I have to use 7.0 until this issue is resolved?
Comment 1 Santer 2012-01-23 12:37:33 UTC
When this issue will be fixed?
Comment 2 Tomas Mysik 2012-01-23 14:23:16 UTC
Weird, perhaps caused by the updated FTP library we use in NetBeans... Anyway, the .svn directory is hidden and should not be listed at all - could it be caused by your server setup? We will try to reproduce and fix, if possible.

(In reply to comment #1)
> When this issue will be fixed?

For NB 7.2 [1], sorry.

Thanks.
[1] http://wiki.netbeans.org/NetBeans_72
Comment 3 Tomas Mysik 2012-01-23 14:24:36 UTC
Ha, sorry, I just noticed that it is about SFTP and not about FTP. The SFTP library has not been updated for NB 7.1 AFAIK.

Anyway, Lado, please, try to reproduce this issue.

Thanks.
Comment 4 Vladimir Riha 2012-01-24 10:41:35 UTC
I can't reproduce it with both "final" 7.1 (fcs) and trunk version of NetBeans. Hidden files aren't downloaded and not even listed in the dialog during project creation


Ubuntu 11.04 32b
JDK 1.7 (b144)
Comment 5 Tomas Mysik 2012-01-24 12:00:06 UTC
Now, I'm able to reproduce with hidden files in subdirectories. I will try to fix it asap.

Thanks.
Comment 6 Tomas Mysik 2012-01-26 06:03:22 UTC
Fixed, Láďo please verify carefully since it is a patch candidate.

Thanks a lot.

http://hg.netbeans.org/web-main/rev/e852ffb6f932
Comment 7 Vladimir Riha 2012-01-27 07:54:20 UTC
Uploading/downloading seems to work, hidden directories and files aren't downloaded or uploaded (except of .htaccess due to default IDE settings), no error during uploading/downloading is shown. 


Product Version: NetBeans IDE Dev (Build web-main-6804-on-20120127)
Java: 1.7.0-ea; Java HotSpot(TM) Client VM 21.0-b14
System: Linux version 2.6.38-8-generic running on i386; UTF-8; en_US (nb)
Comment 8 Marian Mirilovic 2012-01-27 08:47:59 UTC
Tomas, proceed with integration into release71_fixes branch please. Thanks in advance.
Comment 9 Tomas Mysik 2012-01-27 12:58:07 UTC
Transplanted to NB 7.1 patch1 branch, please verify.

Thanks.

http://hg.netbeans.org/releases/rev/ddddf69d0edf
http://hg.netbeans.org/releases/rev/62b5f9bac9de
Comment 10 Vladimir Riha 2012-02-13 12:44:12 UTC
verified 7.1.1

Product Version: NetBeans IDE 7.1.1 (Build 201202122200)