This Bugzilla instance is a read-only archive of historic NetBeans bug reports. To report a bug in NetBeans please follow the project's instructions for reporting issues.

Bug 209029 - "Navigate to Previous/Next Occurrecnces" doubled
Summary: "Navigate to Previous/Next Occurrecnces" doubled
Status: RESOLVED DUPLICATE of bug 194356
Alias: None
Product: editor
Classification: Unclassified
Component: Key bindings (show other bugs)
Version: 7.2
Hardware: All All
: P3 normal (vote)
Assignee: Svata Dedic
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-03-01 09:06 UTC by Tomas Mysik
Modified: 2012-03-23 09:35 UTC (History)
0 users

See Also:
Issue Type: DEFECT
Exception Reporter:


Attachments
screen shot (37.18 KB, image/png)
2012-03-01 09:06 UTC, Tomas Mysik
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Tomas Mysik 2012-03-01 09:06:47 UTC
Created attachment 116227 [details]
screen shot

Clean userdir, have a look at the screenshot, shortcuts are doubled (and they are in the same category).

Thanks.

Product Version: NetBeans IDE Dev (Build 20120301-3120f74e6f64)
Java: 1.6.0_31; Java HotSpot(TM) 64-Bit Server VM 20.6-b01
System: Linux version 3.0.0-16-generic running on amd64; UTF-8; cs_CZ (nb)
Comment 1 Svata Dedic 2012-03-14 13:18:25 UTC
Not sure whether I will be able to fix this in 7.2: those two actions are registered by two different MIME type Editors. Formally, they are completely different actions - and they really have different implementation. 

It is obvious the action should be presented once, and ideally triggered by the same shortcut (which action is invoked depends on user context).
Comment 2 Tomas Mysik 2012-03-14 13:21:45 UTC
Exactly. The biggest problem is that (of course) it is not possible to set just one shortcut for these "doubled" actions :)
Comment 3 Jan Lahoda 2012-03-14 13:26:17 UTC
Probably provide one "name" for each type of actions ("prev-marked-occurrence"/"next-marked-occurrence"), and provide bindings for them in editor itself. Both the Java and (presumably) C/C++ actions should then be automagically merged (as long as they would use the same name). Would revert any user's changes to the bindings of these action from existing userdirs, of course.
Comment 4 Svata Dedic 2012-03-15 09:45:58 UTC
Wouldn't it be better to just abstract even the actions themselves ? There's nothing particular java- or CSL- specific in the current implementations besides the key the marked hightlights are stored - and I think the 'highlight' concept is +- the same for all languages. 

Currently we have 3 copy-pasted impls (CSL, Java, CND)
Comment 5 Vladimir Voskresensky 2012-03-19 19:35:24 UTC
It would be great if we can agree on key which to use to store marked-occurrences bag and common editor infrastructure can have impl of ("prev-marked-occurrence"/"next-marked-occurrence") by getting bag by this key and traversing them.
Comment 6 Vladimir Voskresensky 2012-03-19 19:36:27 UTC
btw, this one is dup of issue #194356
Comment 7 Svata Dedic 2012-03-23 09:35:11 UTC

*** This bug has been marked as a duplicate of bug 194356 ***