This Bugzilla instance is a read-only archive of historic NetBeans bug reports. To report a bug in NetBeans please follow the project's instructions for reporting issues.

Bug 209390 - AssertionError: Null methodName. Signature: [visibleProperty()], Names: [visiblePropertyclone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait]
Summary: AssertionError: Null methodName. Signature: [visibleProperty()], Names: [visi...
Status: RESOLVED FIXED
Alias: None
Product: java
Classification: Unclassified
Component: Editor (show other bugs)
Version: 7.2
Hardware: All All
: P2 normal (vote)
Assignee: Dusan Balek
URL:
Keywords:
: 155903 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-03-09 16:41 UTC by sreimers
Modified: 2012-04-20 07:37 UTC (History)
5 users (show)

See Also:
Issue Type: DEFECT
Exception Reporter: 185236


Attachments
stacktrace (3.67 KB, text/plain)
2012-03-09 16:41 UTC, sreimers
Details
stacktrace (3.67 KB, text/plain)
2012-03-29 05:14 UTC, mkroll
Details
stacktrace (3.67 KB, text/plain)
2012-03-29 15:11 UTC, Alexandr Scherbatiy
Details

Note You need to log in before you can comment on or make changes to this bug.
Description sreimers 2012-03-09 16:41:48 UTC
Build: NetBeans IDE Dev (Build nbms-and-javadoc-8822-on-20120304)
VM: Java HotSpot(TM) 64-Bit Server VM, 23.0-b16, Java(TM) SE Runtime Environment, 1.7.0_04-ea-b14
OS: Windows 7

User Comments:
GUEST: Working in JavaFX code and pressed the . operator and Netbeans never displayed the code completion dialog and instead showed the enclosed exception.

GUEST: want display code completion for Button instance

GUEST: auto complete

GUEST: presses CTRL+SPACE to view javadoc of javafx Rectangle




Stacktrace: 
java.lang.AssertionError: Null methodName. Signature: [visibleProperty()], Names: [visiblePropertyclone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait]
   at org.netbeans.modules.java.source.TreeLoader$3.setParamNames(TreeLoader.java:572)
   at org.netbeans.modules.java.source.TreeLoader$3.handleStartTag(TreeLoader.java:493)
   at javax.swing.text.html.parser.DocumentParser.handleStartTag(DocumentParser.java:160)
   at javax.swing.text.html.parser.Parser.startTag(Parser.java:437)
   at javax.swing.text.html.parser.Parser.parseTag(Parser.java:1948)
   at javax.swing.text.html.parser.Parser.parseContent(Parser.java:2066)
Comment 1 sreimers 2012-03-09 16:41:50 UTC
Created attachment 116520 [details]
stacktrace
Comment 2 mkroll 2012-03-29 05:14:20 UTC
Created attachment 117444 [details]
stacktrace

Edit an in a JavaFX project a .java file.
I whant to add a 
if (usernameField.

At the dot I become the error.
Comment 3 Alexandr Scherbatiy 2012-03-29 15:11:19 UTC
Created attachment 117485 [details]
stacktrace
Comment 4 Exceptions Reporter 2012-03-29 15:11:33 UTC
This bug already has 10 duplicates 
see http://statistics.netbeans.org/exceptions/detail.do?id=185236
Comment 5 Exceptions Reporter 2012-04-10 10:56:24 UTC
This bug already has 20 duplicates 
see http://statistics.netbeans.org/exceptions/detail.do?id=185236
Comment 6 Petr Somol 2012-04-17 13:03:13 UTC
Dusan, it seem this is in your scope. Please reassign if not.
Comment 7 Dusan Balek 2012-04-18 08:18:14 UTC
Fixed in jet-main.

http://hg.netbeans.org/jet-main/rev/98157b302c78
Comment 8 Quality Engineering 2012-04-19 10:01:24 UTC
Integrated into 'main-golden', will be available in build *201204190400* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/98157b302c78
User: Dusan Balek <dbalek@netbeans.org>
Log: Issue #209390: AssertionError: Null methodName. Signature: [visibleProperty()], Names: [visiblePropertyclone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait] - fixed.
Comment 9 Jan Lahoda 2012-04-20 07:37:17 UTC
*** Bug 155903 has been marked as a duplicate of this bug. ***