This Bugzilla instance is a read-only archive of historic NetBeans bug reports. To report a bug in NetBeans please follow the project's instructions for reporting issues.

Bug 215906 - braces matching tooltip is not displayed correctly
Summary: braces matching tooltip is not displayed correctly
Status: RESOLVED DUPLICATE of bug 205840
Alias: None
Product: editor
Classification: Unclassified
Component: Painting & Printing (show other bugs)
Version: 7.3
Hardware: PC Mac OS X
: P3 normal (vote)
Assignee: Miloslav Metelka
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-07-24 21:18 UTC by athompson
Modified: 2013-01-08 14:59 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
Exception Reporter:


Attachments
braces matching tooltip is shown with the wrong width and height (197.80 KB, image/png)
2012-07-24 21:18 UTC, athompson
Details

Note You need to log in before you can comment on or make changes to this bug.
Description athompson 2012-07-24 21:18:09 UTC
Created attachment 122325 [details]
braces matching tooltip is shown with the wrong width and height

1. Open a java file.
2. Scroll the file in the editor so that a starting brace is off the page but the corresponding ending brace is on the page.
3! Hover over the brace.  The tooltip for the starting brace is shown, but with an incorrect width and height.

This may be related to issue #215905, but I'm not sure.

Product Version: NetBeans IDE Dev (Build 201207201342)
Java: 1.6.0_33; Java HotSpot(TM) 64-Bit Server VM 20.8-b03-424
System: Mac OS X version 10.8 running on x86_64; MacRoman; en_US (nb)
User directory: /Users/alvin/Library/Application Support/NetBeans/dev
Cache directory: /Users/alvin/Library/Caches/NetBeans/dev
Comment 1 athompson 2012-07-27 15:41:36 UTC
Yup, it's caused by the "line wrap" option being on--the same as issue #215905.
Comment 2 Jiri Prox 2012-07-27 16:19:06 UTC
Do you use and 3rd party plugin for displaying braces matching tooltip?
Comment 3 athompson 2012-07-27 16:31:22 UTC
Nope, it's an option in the recent daily builds.
Comment 4 Svata Dedic 2012-11-21 08:08:03 UTC
Note - this is most probably a duplicate of 222112 and/or 205840 (applies also to code fold popups). Note the wrap indicator in the screenshot.
Comment 5 Milutin Kristofic 2013-01-08 14:59:34 UTC

*** This bug has been marked as a duplicate of bug 205840 ***