This Bugzilla instance is a read-only archive of historic NetBeans bug reports. To report a bug in NetBeans please follow the project's instructions for reporting issues.

Bug 216404 - Hover over folded code displays in narrow window
Summary: Hover over folded code displays in narrow window
Status: RESOLVED DUPLICATE of bug 205840
Alias: None
Product: editor
Classification: Unclassified
Component: Code folding (show other bugs)
Version: 7.2
Hardware: PC Linux
: P3 normal (vote)
Assignee: Svata Dedic
URL:
Keywords:
Depends on: 205840
Blocks:
  Show dependency tree
 
Reported: 2012-08-05 00:43 UTC by berniev
Modified: 2012-10-03 06:41 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
Exception Reporter:


Attachments
Java Code Folds Preview Only Line numbers (70.42 KB, image/jpeg)
2012-08-22 08:59 UTC, battal84
Details
Netbeans userDir/config area for 7.2 and 7.1.2 (214.60 KB, application/zip)
2012-09-06 09:07 UTC, battal84
Details
berniev: Product Version: NetBeans IDE 7.2 (Build 201207171143) config folder (160.93 KB, application/zip)
2012-09-06 23:33 UTC, berniev
Details

Note You need to log in before you can comment on or make changes to this bug.
Description berniev 2012-08-05 00:43:23 UTC
Product Version = NetBeans IDE 7.2 (Build 201207171143)
Operating System = Linux version 3.0.0-23-generic-pae running on i386
Java; VM; Vendor = 1.6.0_24
Runtime = OpenJDK Client VM 20.0-b12

Comments from experience with php.

Hover over folded code {...} displays the text within the fold.

But the pop up display window width is erratic and often very narrow even if there is plenty of available space on the screen.
This results in a long thin window with lots of line continuations.
Suggest the window should be as wide as necessary to display folded text, up to the available editor window width.
Comment 1 Svata Dedic 2012-08-05 07:09:58 UTC
Please check your settings - what is set in Tools | Options | Editor > All Languages, Line Wrap ? There were some troubles reported in the past for certain wrapping types.
Comment 2 berniev 2012-08-06 19:40:27 UTC
Currently Tools->Options->Editor->Formatting->AllLanguages set to "Off". Tried other settings but didn't seem to affect the width of the fold pop up at all.
Comment 3 Svata Dedic 2012-08-06 19:43:09 UTC
OK, so you have wrapping off and still see narrow fold tooltip - right ? 

Please attach a screenshot (or send by email) if possible, so I can see how the text in the popup is arranged; blur the actual content if necessary. Try to measure the NetBeans window size or if maximized, what's your screen size in px ? How the layout of your IDE looks like (screenshot ?) If you could extract a portion of code, which leads to the error.
Comment 4 aleforla 2012-08-18 21:27:46 UTC
In my installation (Win XP) an old font&color scheme (imported from previous NB versions) caused the popup of folded code to be displayed as narrow as only the folded line numbers were visible.

This defect seamed to be caused by the fact that in the font&color scheme I have selected (as "default" font for "all languages" a non monospaced font).

When I changed the default font to a monospaced font the defect disapeared.
Comment 5 berniev 2012-08-20 03:49:54 UTC
sorry sdedic, missed yr post.

I would supply a screen shot if I knew how. A soon as I use the tools I have the hover disappears!

Using default mono spaced font.

Pop up hover display window width same if Netbeans window maximised or not.

Screen 1280 x 1024. Changed to 800 x 600 for you. Popup window same width i.e. same number of characters wide.

I think it happens with any folded code, even:
<?php

/*
 * To change this template, choose Tools | Templates
 * and open the template in the editor.
 */
?>
Comment 6 battal84 2012-08-22 08:59:58 UTC
Created attachment 123385 [details]
Java Code Folds Preview Only Line numbers

On Ubuntu 12.04, Netbeans 7.2 fresh installed... When I hover on code folds, it only shows line numbers as preview; while Netbeans 7.1.2 correctly shows code preview.
Comment 7 battal84 2012-08-22 09:01:39 UTC
I'm experiencing a similar issue with Java code folds. (see my attachment)
Java code folds only preview as line numbers on Netbeans 7.2 .

Netbeans 7.1.2 didn't have this issue.
Comment 8 Svata Dedic 2012-09-06 08:12:50 UTC
I am really sorry, but I cannot reproduce it in dev build, tried different screen resolutions, layout according to the screenshot, monospaced or proportional fonts. Could you please zip and attach your $userdir/config area, so I can get the environment settings.

Thanks.
Comment 9 battal84 2012-09-06 09:07:24 UTC
Created attachment 123977 [details]
Netbeans userDir/config area for 7.2 and 7.1.2

I'm sending a zip file contanining config folders of my current Netbeans 7.2 (which contains the defect) and old 7.1.2 for reference.
Comment 10 berniev 2012-09-06 15:19:56 UTC
I see a config folder in each of ide, php and nb netbeans7.2 folders. 
Are these the ones you want? If not please advise!
Comment 11 Svata Dedic 2012-09-06 18:23:23 UTC
(In reply to comment #10)
> I see a config folder in each of ide, php and nb netbeans7.2 folders. 
> Are these the ones you want? If not please advise!

When running the 'buggy' installation, display Help | About, the user directory location is listed in the lower part of the dialog. The 'config' subdirectory should be in there. Remember to note the exact version of the IDE; or pack in the var/log/messages.log file as well.
Thanks !
Comment 12 berniev 2012-09-06 23:33:46 UTC
Created attachment 124006 [details]
berniev: Product Version: NetBeans IDE 7.2 (Build 201207171143) config folder
Comment 13 Svata Dedic 2012-09-07 11:14:36 UTC
I can confirm the defect appearing on berniev's config, iff there's "line wrap" set to "anywhere". In the supplied config, the line wrap is turned on for PHP specifically. If I enable it for Java, the IDE also starts to display code folding tooltips in a trimmed window. 
Unlike screenshot supplied by battal84, I can see some portion of the text, not just line numbers.
Comment 14 Svata Dedic 2012-09-07 11:38:29 UTC
I didn't reproduce the defect using battal84's settings, sadly, neither for Java or PHP.

Marking this defect as a duplicate of the #205840.

*** This bug has been marked as a duplicate of bug 205840 ***
Comment 15 battal84 2012-10-03 06:40:46 UTC
(In reply to comment #14)
> I didn't reproduce the defect using battal84's settings, sadly, neither for
> Java or PHP.
> 
> Marking this defect as a duplicate of the #205840.
> 
> *** This bug has been marked as a duplicate of bug 205840 ***

Today's updates fixed it for me.
Comment 16 battal84 2012-10-03 06:41:37 UTC
(In reply to comment #14)
> I didn't reproduce the defect using battal84's settings, sadly, neither for
> Java or PHP.
> 
> Marking this defect as a duplicate of the #205840.
> 
> *** This bug has been marked as a duplicate of bug 205840 ***

Today's updates have fixed it for me.