This Bugzilla instance is a read-only archive of historic NetBeans bug reports. To report a bug in NetBeans please follow the project's instructions for reporting issues.

Bug 217036 - GIT Push: "remote does not support smart HTTP push"
Summary: GIT Push: "remote does not support smart HTTP push"
Alias: None
Product: versioncontrol
Classification: Unclassified
Component: Git (show other bugs)
Version: 8.0.2
Hardware: PC Linux
: P3 normal (vote)
Assignee: Ondrej Vrabec
Depends on:
Reported: 2012-08-17 13:36 UTC by BreyndotEchse
Modified: 2016-09-16 08:35 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
Exception Reporter:

IDE log (53.86 KB, text/plain)
2012-08-17 13:36 UTC, BreyndotEchse
Logfile with stack trace (43.74 KB, text/plain)
2016-09-16 08:32 UTC, mrelleum

Note You need to log in before you can comment on or make changes to this bug.
Description BreyndotEchse 2012-08-17 13:36:46 UTC
Product Version = NetBeans IDE 7.2 (Build 201207301726)
Operating System = Windows 7 version 6.1 running on x86
Java; VM; Vendor = 1.6.0_31
Runtime = Java HotSpot(TM) Client VM 20.6-b01

Well... I'm pretty sure it does.
I checked my remote configuration several times and could not find any mistake. So i tried to push my repository by using "GIT GUI".
That worked perfectly without any errors.
Comment 1 BreyndotEchse 2012-08-17 13:36:53 UTC
Created attachment 123258 [details]
IDE log
Comment 2 Ondrej Vrabec 2012-08-22 12:33:43 UTC
> Well... I'm pretty sure it does.
> I checked my remote configuration several times
Really? Did you check configuration of the remote in .git/config or the configuration on the server?
The message means that your repository does not support smart http upload. In other words, it does not respond with the expected content-type (application/x-git-receive-pack-advertisement) and content for the following get request: REPOSITORY_URL/info/refs?service=git-receive-pack
If the server is public, let me know its URL. If it is a private one and you can configure it, make sure it sends the correct response.
Comment 3 jbcrouigneau 2015-04-28 16:18:22 UTC

I got the same issue.
I tried to push with Netbeans 8.0.2 : got the error "remote does not support smart HTTP push".
In the same repository, I used command line ("git push origin master"), it worked.

I think that if it works with command line, that is not a server issue but a Netbeans issue.

I work with a private server and access git through apache/WebDAV with a self-signed certificate.

Here is my apache config :

<VirtualHost *:443>
    ErrorLog /var/log/apache2/git-error.log
    DocumentRoot /var/git
    SSLEngine On
    SSLCertificateFile /etc/apache2/ssl/
    SSLCertificateKeyFile /etc/apache2/ssl/

    SetEnv GIT_PROJECT_ROOT /var/git
    ScriptAliasMatch "(?x)^/git/(.*/(HEAD | info/refs | objects/(info/[^/]+ | [0-9a-f]{2}/[0-9a-f]{38} | pack/pack-[0-9a-f]{40}\.(pack|idx)) | git-(uploa
d|receive)-pack))$" /usr/lib/git-core/git-http-backend/$1

    <Directory "/usr/lib/git-core/">
        AllowOverride None
        Options +ExecCGI -Includes
        Order allow,deny
        Allow from all

    <Location />
        DAV on
        AuthType Basic
        AuthName "Git Repository"
        AuthUserFile /etc/apache2/dav_svn.passwd
        Require valid-user
Comment 4 Ondrej Vrabec 2015-04-28 17:39:36 UTC
Attach the IDE log with the error.
Comment 5 Ondrej Vrabec 2015-07-07 14:13:02 UTC
Please try with 8.0.2 and attach the IDE log with the error from there. Thanks.
Comment 6 mrelleum 2016-09-16 08:32:49 UTC
Created attachment 162074 [details]
Logfile with stack trace

just to add some more information in case it helps.
Comment 7 mrelleum 2016-09-16 08:35:29 UTC
Additional Note: 
Push to our company internal git server using http from Git for Windows worked without problems.