This Bugzilla instance is a read-only archive of historic NetBeans bug reports. To report a bug in NetBeans please follow the project's instructions for reporting issues.

Bug 217833 - Refactoring is always closing Reduced Tree package nodes
Summary: Refactoring is always closing Reduced Tree package nodes
Status: RESOLVED DUPLICATE of bug 211847
Alias: None
Product: projects
Classification: Unclassified
Component: Generic Projects UI (show other bugs)
Version: 7.3
Hardware: PC Windows 7 x64
: P2 normal (vote)
Assignee: Milos Kleint
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-09-04 16:01 UTC by crazyjavahacking
Modified: 2012-09-04 20:04 UTC (History)
0 users

See Also:
Issue Type: DEFECT
Exception Reporter:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description crazyjavahacking 2012-09-04 16:01:19 UTC
It is very annoying that refactoring (including Rename refactoring, Move refactoring and sometimes Remove class as well) is always closing package nodes in Reduced Tree package view.

I used to close not necessary package nodes when focusing on code and this "behavior" is very annoying making the Reduced Tree package view almost unusable (for big nested package hierarchies).
Comment 1 crazyjavahacking 2012-09-04 16:01:55 UTC
NetBeans Dev 201209040001, JDK 7u5 32bit, Win7 SP1 64bit
Comment 2 Ralph Ruijs 2012-09-04 18:08:10 UTC
Maybe a duplicate of 216232 or 211847 ?
Comment 3 crazyjavahacking 2012-09-04 20:04:51 UTC
Yes, this bug is a duplicate so I am closing it and commenting the 211847 one.

*** This bug has been marked as a duplicate of bug 211847 ***