This Bugzilla instance is a read-only archive of historic NetBeans bug reports. To report a bug in NetBeans please follow the project's instructions for reporting issues.

Bug 219100 - Syntax categories for CSS are not related to correct elements in preview
Summary: Syntax categories for CSS are not related to correct elements in preview
Status: RESOLVED DUPLICATE of bug 213944
Alias: None
Product: editor
Classification: Unclassified
Component: CSL (API & infrastructure) (show other bugs)
Version: 7.2
Hardware: Macintosh (x86) Mac OS X
: P3 normal (vote)
Assignee: Milutin Kristofic
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-09-27 06:07 UTC by alfamikedelta
Modified: 2012-11-28 23:28 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
Exception Reporter:


Attachments
CSS Syntax coloring for NB 7.0.1 (101.46 KB, image/png)
2012-09-27 06:07 UTC, alfamikedelta
Details
CSS Syntax coloring for NB 7.2 (95.96 KB, image/png)
2012-09-27 06:08 UTC, alfamikedelta
Details

Note You need to log in before you can comment on or make changes to this bug.
Description alfamikedelta 2012-09-27 06:07:45 UTC
Created attachment 124991 [details]
CSS Syntax coloring for NB 7.0.1

Using NB 7.2 for PHP.

In Preferences -> Fonts & Colors -> Syntax, when you are previewing syntax coloring for CSS, some of the categories do not represent the correct element in preview, for example when viewing the category "Selector" it is supposed to mark/change "h1, h2 > h3" elements.

Also, the preview window shows some of the text as black text instead of the real colors.

Tested the same with NB 7.0.1 and it works perfect.

This does not affect syntax coloring in the CSS editor except when you upgrade from NB 7.0.1 to 7.2 and choose to import settings to new install. In this case the text appears all black for the CSS editor too.
Comment 1 alfamikedelta 2012-09-27 06:08:25 UTC
Created attachment 124992 [details]
CSS Syntax coloring for NB 7.2
Comment 2 alfamikedelta 2012-09-27 06:09:19 UTC
My system info:

Product Version = NetBeans IDE 7.2 (Build 201207171143)
Operating System = Mac OS X version 10.6.8 running on x86_64
Java; VM; Vendor = 1.6.0_35
Runtime = Java HotSpot(TM) 64-Bit Server VM 20.10-b01-428
Comment 3 David Strupl 2012-11-13 14:16:03 UTC
CSS editor owner, can you please evaluate? Whether the problem is just CSS related or general? Thanks.
Comment 4 Marek Fukala 2012-11-28 19:59:11 UTC
The css source sample doesn't contain the semantic colorings which in case of css colors significant part of the syntax elements. 

As the semantic coloring is purely CSL based, I believe the issue belongs there.
Comment 5 Milutin Kristofic 2012-11-28 23:28:46 UTC

*** This bug has been marked as a duplicate of bug 213944 ***