Bug 220636 - Design and implement Ordering/Grouping mechanism
Summary: Design and implement Ordering/Grouping mechanism
Status: RESOLVED FIXED
Alias: None
Product: connecteddeveloper
Classification: Unclassified
Component: Task Dashboard (show other bugs)
Version: 7.2
Hardware: PC Windows 7
: P1 normal (vote)
Assignee: Jan Peska
URL:
Keywords:
: 212787 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-10-23 09:27 UTC by Jan Peska
Modified: 2013-11-06 09:09 UTC (History)
0 users

See Also:
Issue Type: ENHANCEMENT
Exception Reporter:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jan Peska 2012-10-23 09:27:58 UTC
Further evaluation needed. 

1) 
Bugtracking API needs to provide a mechanism for grouping tasks. Dashboard needs to know how to group and by what to group (e.g. provide a set of attributes for grouping).


2)
Enable grouping for categories? If yes, how to handle different grouping attributes from different repositories within one category.
Comment 1 Jan Peska 2013-08-29 13:26:46 UTC
*** Bug 212787 has been marked as a duplicate of this bug. ***
Comment 2 Jan Peska 2013-08-29 13:57:36 UTC
We have to decide if we will use original specification for grouping (and resolve pending issues) or if we design more lightweight ordering mechanism.

Original spec: http://wiki.netbeans.org/TaskDashboardDesignSpec
Comment 3 Jan Peska 2013-10-03 13:57:57 UTC
fix: http://hg.netbeans.org/core-main/rev/2ced7a92c4e0
Comment 4 Jan Peska 2013-11-06 09:09:21 UTC
We decided to use just editable sorting - no grouping implemented.