This Bugzilla instance is a read-only archive of historic NetBeans bug reports. To report a bug in NetBeans please follow the project's instructions for reporting issues.

Bug 223668 - Please introduce a way for providing a path to a file (referenced with FileDescriptor) without getting FileObject
Summary: Please introduce a way for providing a path to a file (referenced with FileDe...
Status: RESOLVED FIXED
Alias: None
Product: utilities
Classification: Unclassified
Component: Jump To (show other bugs)
Version: 7.3
Hardware: All All
: P3 normal (vote)
Assignee: Tomas Zezula
URL:
Keywords:
Depends on:
Blocks: 218774
  Show dependency tree
 
Reported: 2012-12-11 14:53 UTC by Andrew Krasny
Modified: 2012-12-13 09:08 UTC (History)
0 users

See Also:
Issue Type: DEFECT
Exception Reporter:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Andrew Krasny 2012-12-11 14:53:35 UTC
The request comes from http://netbeans.org/bugzilla/show_bug.cgi?id=218774 investigation. The problem is that infrastructure asks for a FileObject from withing the EDT, which could lead to UI freezes..
Comment 1 Tomas Zezula 2012-12-12 10:23:00 UTC
Fixed jet-main 1b708ddbabfe
Comment 2 Quality Engineering 2012-12-13 02:38:53 UTC
Integrated into 'main-golden', will be available in build *201212130001* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/1b708ddbabfe
User: Tomas Zezula <tzezula@netbeans.org>
Log: #223668:Please introduce a way for providing a path to a file (referenced with FileDescriptor) without getting FileObject