This Bugzilla instance is a read-only archive of historic NetBeans bug reports. To report a bug in NetBeans please follow the project's instructions for reporting issues.

Bug 225286 - edited file is not selected in "project file list"
Summary: edited file is not selected in "project file list"
Status: RESOLVED DUPLICATE of bug 218752
Alias: None
Product: php
Classification: Unclassified
Component: Code (show other bugs)
Version: 7.4
Hardware: PC Windows 7
: P3 normal (vote)
Assignee: Tomas Mysik
URL:
Keywords: RANDOM
: 236747 (view as bug list)
Depends on:
Blocks:
 
Reported: 2013-01-24 13:55 UTC by norbi771
Modified: 2013-11-14 06:26 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
Exception Reporter:


Attachments
screenshot (130.66 KB, image/gif)
2013-01-24 13:55 UTC, norbi771
Details

Note You need to log in before you can comment on or make changes to this bug.
Description norbi771 2013-01-24 13:55:37 UTC
Created attachment 130586 [details]
screenshot

When working with NB Dev nbms-and-javadoc-10136-on-20130122 if I edit the PHP file, it is not selected Project's file list. Even if I am trying to force this by right click and "Select in projects" option on the edited file's tab. 
On the contrary, if I switch from Projects to Files, the edited file is immediately selected.
Comment 1 Martin Kanak 2013-01-31 12:16:06 UTC
Right click and "Select in projects" option works for me properly. 

But I am not sure how it is with selecting the file in Projects during editing this file. Such behavior does not occur even in other languages (Java, HTML,...), so I think that the file would not be selected automatically in Projects when editing. Am i right, Tomasi?

Product Version: NetBeans IDE Dev (Build 201301310001)
Java: 1.7.0_10-ea; Java HotSpot(TM) 64-Bit Server VM 23.6-b04
Runtime: Java(TM) SE Runtime Environment 1.7.0_10-ea-b17
System: Linux version 3.2.0-36-generic running on amd64; UTF-8; en_US (nb)
Comment 2 Tomas Mysik 2013-01-31 13:29:44 UTC
It works for me properly as well but there were already such reports in the past so likely the bug is there but unfortunately is random...

(In reply to comment #1)
> But I am not sure how it is with selecting the file in Projects during editing
> this file. Such behavior does not occur even in other languages (Java,
> HTML,...), so I think that the file would not be selected automatically in
> Projects when editing. Am i right, Tomasi?

Sorry, no idea.

Thanks.
Comment 3 Vladimir Riha 2013-02-04 12:35:42 UTC
Out of curiosity I tried to check "View|Synchronize Editor and Views" and that does the trick, focused file is being focused in Projects window as well. And it seems to work fine


Product Version: NetBeans IDE 7.3 RC2 (Build 201302032200)
Java: 1.7.0_13; Java HotSpot(TM) Client VM 23.7-b01
Runtime: Java(TM) SE Runtime Environment 1.7.0_13-b20
System: Linux version 3.2.0-35-generic-pae running on i386; UTF-8; en_US (nb)
Comment 4 Tomas Mysik 2013-07-22 05:23:42 UTC
Unfortunately, without a way to reproduce this issue it is hard to fix it... :/
Comment 5 Tomas Mysik 2013-10-09 05:50:40 UTC
*** Bug 236747 has been marked as a duplicate of this bug. ***
Comment 6 Tomas Mysik 2013-11-14 06:26:40 UTC

*** This bug has been marked as a duplicate of bug 218752 ***