This Bugzilla instance is a read-only archive of historic NetBeans bug reports. To report a bug in NetBeans please follow the project's instructions for reporting issues.

Bug 230809 - [74cat] Can't install if user dir on a server
Summary: [74cat] Can't install if user dir on a server
Alias: None
Product: installer
Classification: Unclassified
Component: NBI (show other bugs)
Version: 7.4
Hardware: PC Other
: P1 normal (vote)
Assignee: Libor Fischmeistr
Depends on:
Reported: 2013-06-05 20:53 UTC by muellermi
Modified: 2013-06-17 11:18 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
Exception Reporter:

error message (28.23 KB, image/png)
2013-06-06 06:27 UTC, muellermi
Install log file. (84.29 KB, application/octet-stream)
2013-06-11 06:28 UTC, muellermi
Screenshot error message (27.92 KB, image/png)
2013-06-14 06:45 UTC, muellermi

Note You need to log in before you can comment on or make changes to this bug.
Description muellermi 2013-06-05 20:53:15 UTC
OS: Windows 6.2 aka "8"
%userprofile% points to a remote directory (on fileserver)

run NB installer
enter all directories (use defaults on local drive)
on last page (JUnit will be installed..), the current nightly build alerts something like
"64.4 MByte needed on \\fileserver\"
and the next button is disabled. Thus, no install is possible.

(this is the server %userprofile% points to)

It seems, this message will be displayed regardless the available space (in my case > 30 GB).
Comment 1 muellermi 2013-06-06 06:27:52 UTC
Created attachment 135413 [details]
error message
Comment 2 muellermi 2013-06-06 06:29:05 UTC
Same problem happened using Windows 6.1 "7"
I'm downloading next nightly build to check again.
(No problem with 7.3)
Comment 3 muellermi 2013-06-06 06:37:14 UTC
Same problem with current netbeans-trunk-nightly-201306052301-javaee-windows

I double-checked with an older version(netbeans-trunk-nightly-201302122300-javaee-windows): no such problem.
Comment 4 Libor Fischmeistr 2013-06-06 06:56:57 UTC
Hello, the installer log would be great.
Comment 5 muellermi 2013-06-06 14:54:02 UTC
If there would be any log file, I'd provided them.
Cannot find any .nbi dir nor a log :(

But I do not have any chance to install (with the installer version). Thus doN#t close as incomplete!!!
Comment 6 muellermi 2013-06-06 14:56:57 UTC
Hm, thinking about the missing log file: 
It seems NBI (in current version) cannot access a remote %userprofile% at all.
Comment 7 Antonin Nebuzelsky 2013-06-10 12:19:04 UTC
(In reply to comment #6)
> Hm, thinking about the missing log file: 
> It seems NBI (in current version) cannot access a remote %userprofile% at all.

Can you please run the installer from command line with the following parameters?

  --verbose --output localpathtologfile
Comment 8 muellermi 2013-06-11 06:28:50 UTC
Created attachment 135615 [details]
Install log file.
Comment 9 muellermi 2013-06-11 06:50:10 UTC
netbeans-trunk-nightly-201306102301-javaee-windows.exe still faces the same problem
Comment 10 Libor Fischmeistr 2013-06-11 14:28:22 UTC
Can I ask you to describe how to point userprofile to a remote directory?
Comment 11 muellermi 2013-06-11 15:10:11 UTC
1. open active directory user and computer
2. choose your domain, your organisation, user folder
3. right click on user of your choice
4. select properties
5. select tab profile
6. enter profile path, e.g. \\fileserver\profile$\mullermi

\\fileserver is the server, 
\profile$ is the share ($ indicates a system or hidden share)
\muellermi is the user

Hopefully everything is right. Otherwise i have to wait for the admin back from vacation...

As I stated before, there is no such problem with an older version of the NB installer, e.g. 7.3
Comment 12 muellermi 2013-06-12 06:11:51 UTC
Re-thinking about this problem:

- log in as windows user
- start installation
--> windows asks for administrative user
--> installation starts
- enter some directory info during installation process
--> NBI reports insufficient disk space

NBI reports insufficient disk space for standard user!
But during installation NBI switches to admin user. This user has no access to user profiles.
If my thoughts are right, it must be possible to install when I log in as administrative user. I'm going to check this.

On the other hand, it must be a problem to install, even if the user uses a local 
profile (not a server [remote] profile). But at home, I could install. (local profile, standard user)
Comment 13 muellermi 2013-06-12 06:25:19 UTC
My thoughts had been right: No problem to install if loged in as administrative user.

This is the matrix of success:

                     local                 server
                     profile               profile

standard user        ok (1)                no install

admin user           ok                    ok

(1) I'm going to double-check. Might take some days.
Comment 14 muellermi 2013-06-12 07:02:58 UTC
I wanted to create a new project with the fresh installation. Usually, I use a folder on drive d:.

But, creating a new project for the first time with this version, it points to the default location, which seems to be "%homepath%\my documents\NetBeansProjects".
In my case, this is stored on a server, too. It points to \\Fileserver1\User$\muellermi\Eigene Dateien\NetBeansProjects.

NB alerts "Project Folder cannot be located on UNC path."

- Might this be related to the installer problem?
- Why can it not be located on a valid UNC path? (I think, I'l file another issue)
Comment 15 muellermi 2013-06-12 13:38:10 UTC
I just downloaded the final version 7.3.1.
Unlike the current dev version, there is no such problem. I'm happy with that version.

Please compare NBI 7.3.1 final (ok) to NBI 7.3.1 ["7.4"] build 201306112301 (buggy). Thanks!
Comment 16 muellermi 2013-06-13 06:16:06 UTC
See issue 221112, maven repo problem. It seems to have the same cause. There must be a library for unc path in the dev version, which has been changed some days or weeks ago.
Comment 17 Libor Fischmeistr 2013-06-13 09:06:03 UTC
Thank you very much for all info. Yesterday I was trying to reproduce by setting up the userprofile to remote loaction. I was unsuccessful with it but then I tried to reproduce it a little bit differently.

I mapped the network disk and then I tried to install NB on it. I got the same message. Now I'm going to debug it an we will see.
Comment 18 muellermi 2013-06-13 11:53:59 UTC
Glad to hear, you could reproduce it.

BTW, I made a typo
See issue 221112, maven repo problem. 

This is the correct one
See issue 231112, maven repo problem.
Comment 19 Libor Fischmeistr 2013-06-13 13:20:06 UTC
Fixed in

Caused by

The part of that changeset has been reverted.
Comment 20 Libor Fischmeistr 2013-06-13 13:50:10 UTC
Also pushed into release74_beta branch
Comment 21 Quality Engineering 2013-06-14 00:49:55 UTC
Integrated into 'releases', will be available in build *201306132201* or newer. Wait for official and publicly available build.
User: Libor Fischmeistr <>
Log: #230809: [74cat] Can't install if user dir on a server
Comment 22 muellermi 2013-06-14 06:44:47 UTC
I tested with netbeans-trunk-nightly-201306132301-javaee-windows.
The problem still exists :(
Comment 23 muellermi 2013-06-14 06:45:49 UTC
Created attachment 135783 [details]
Screenshot error message
Comment 24 Libor Fischmeistr 2013-06-14 07:42:26 UTC
(In reply to comment #22)
> I tested with netbeans-trunk-nightly-201306132301-javaee-windows.
> The problem still exists :(

It seems it's not in that build yet...
Comment 25 Quality Engineering 2013-06-15 03:05:11 UTC
Integrated into 'main-golden', will be available in build *201306142301* on (upload may still be in progress)
User: Libor Fischmeistr <>
Log: #230809: [74cat] Can't install if user dir on a server
Comment 26 Antonin Nebuzelsky 2013-06-17 10:24:52 UTC
(In reply to comment #25)
> available in build *201306142301*

muellermi, can you please verify?
Comment 27 muellermi 2013-06-17 11:01:54 UTC
Checked against netbeans-trunk-nightly-201306162301-javaee-windows: ok!
Comment 28 Libor Fischmeistr 2013-06-17 11:18:27 UTC
(In reply to comment #27)
> Checked against netbeans-trunk-nightly-201306162301-javaee-windows: ok!

Thank you