This Bugzilla instance is a read-only archive of historic NetBeans bug reports. To report a bug in NetBeans please follow the project's instructions for reporting issues.

Bug 231224 - Support For "Organize Imports On Save"
Summary: Support For "Organize Imports On Save"
Status: RESOLVED DUPLICATE of bug 217904
Alias: None
Product: java
Classification: Unclassified
Component: Editor (show other bugs)
Version: 7.4
Hardware: Macintosh Mac OS X
: P3 normal (vote)
Assignee: Dusan Balek
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-06-13 14:29 UTC by abien
Modified: 2013-06-14 09:42 UTC (History)
0 users

See Also:
Issue Type: DEFECT
Exception Reporter:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description abien 2013-06-13 14:29:48 UTC
Product Version = NetBeans IDE Dev (Build 201306112301)
Operating System = Mac OS X version 10.8.4 running on x86_64
Java; VM; Vendor = 1.7.0_21
Runtime = Java HotSpot(TM) 64-Bit Server VM 23.21-b01

Implement / enable a new action for "Organize Imports" on save. 

Also: On Save actions should be customizable. E.g. It should be possible to choose an action (e.g. by key bindings) to be executed on save.
Comment 1 Dusan Balek 2013-06-14 09:42:26 UTC
Already implemented in the current dev build.

*** This bug has been marked as a duplicate of bug 217904 ***