This Bugzilla instance is a read-only archive of historic NetBeans bug reports. To report a bug in NetBeans please follow the project's instructions for reporting issues.

Bug 233151 - Code completion text too small
Summary: Code completion text too small
Status: RESOLVED FIXED
Alias: None
Product: editor
Classification: Unclassified
Component: Completion & Templates (show other bugs)
Version: 7.4
Hardware: PC Linux
: P3 normal (vote)
Assignee: Milutin Kristofic
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-07-22 08:16 UTC by Tomas Mysik
Modified: 2013-07-25 05:10 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
Exception Reporter:


Attachments
screenshot (58.00 KB, image/png)
2013-07-22 08:16 UTC, Tomas Mysik
Details
patch (1.61 KB, patch)
2013-07-22 13:01 UTC, Milutin Kristofic
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Tomas Mysik 2013-07-22 08:16:49 UTC
Created attachment 137530 [details]
screenshot

See attached screenshot. Just noticed it in today's build, it was OK last week.

Thanks.

Product Version: NetBeans IDE Dev (Build 20130722-3270cb4b91f6)
Java: 1.7.0_25; Java HotSpot(TM) 64-Bit Server VM 23.25-b01
Runtime: Java(TM) SE Runtime Environment 1.7.0_25-b15
System: Linux version 3.8.0-26-generic running on amd64; UTF-8; cs_CZ (nb)
Comment 1 Tomas Mysik 2013-07-22 08:21:27 UTC
BTW sorry if this is not the proper BZ component. Thanks.
Comment 2 Dusan Balek 2013-07-22 12:07:47 UTC
Seems to be caused by:
Changeset: http://hg.netbeans.org/main-silver/rev/153262c40a05
User: Milutin Kristofic <mkristofic@netbeans.org>
Comment 3 Tomas Mysik 2013-07-22 12:14:59 UTC
Perhaps setting proper font [1] could help.

Thanks.
[1] jEditorPane.setFont(new JLabel().getFont())
Comment 4 Milutin Kristofic 2013-07-22 13:01:05 UTC
Created attachment 137559 [details]
patch

I was asked for Honor_display_property in Bug #231808. It is also in javadoc window. 

I can fix size with
Comment 5 Milutin Kristofic 2013-07-22 13:02:58 UTC
It's not in my modules, but I think it can be fixed with setFont value (in patch), if owners allow.
Comment 6 Milutin Kristofic 2013-07-23 13:13:46 UTC
http://hg.netbeans.org/jet-main/rev/92bb32dd1b8c
Comment 7 Quality Engineering 2013-07-25 02:29:19 UTC
Integrated into 'main-silver', will be available in build *201307242300* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)

Changeset: http://hg.netbeans.org/main-silver/rev/92bb32dd1b8c
User: Milutin Kristofic <mkristofic@netbeans.org>
Log: #233151 - Code completion text too small
Comment 8 Tomas Mysik 2013-07-25 05:10:04 UTC
The font seems to me to be different than it used to be... or am I wrong?

Thanks.