This Bugzilla instance is a read-only archive of historic NetBeans bug reports. To report a bug in NetBeans please follow the project's instructions for reporting issues.

Bug 234484 - Cannot debug when IDE is running on JDK7 and FX Project uses JDK8
Summary: Cannot debug when IDE is running on JDK7 and FX Project uses JDK8
Alias: None
Product: javafx
Classification: Unclassified
Component: Debugger (show other bugs)
Version: 7.4
Hardware: PC All
: P3 normal with 1 vote (vote)
Assignee: Roman Svitanic
Keywords: JDK_8
: 237579 (view as bug list)
Depends on:
Reported: 2013-08-16 10:00 UTC by JoergWille
Modified: 2013-12-21 07:00 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
Exception Reporter:


Note You need to log in before you can comment on or make changes to this bug.
Description JoergWille 2013-08-16 10:00:40 UTC
Cannot debug in a new created javafx application using jdk1.8 102.
I tried Netbeans 7.4beta and some nightly builds up to 201308152300. Only tried on MacOS X 10.8.4.
I go to File > New Project > JavaFX Application
I assign the JavaFX platform to JDK 1.8 and hit finish
When I run the newly created project, the program runs BUT when I debug into (set breakpoint an hit debug) it I get a window titled "JavaFX Launcher" with the following message: "This application requires a newer version of the Java runtime. Please download and install the latest Java runtime from Then restart the application."
Might be duplicate of 231756 but they reported a fix for Windows 64
Comment 1 JoergWille 2013-08-16 10:48:54 UTC
I forget: Netbeans itself uses jdk1.7.0_25
Comment 2 Roman Svitanic 2013-08-16 12:13:07 UTC
I can confirm this issue on Win7 x64 + JDK8 b103, NetBeans Dev 20130815.
Comment 3 Roman Svitanic 2013-09-03 15:02:50 UTC
Issue is present only when IDE is running on JDK7 and FX Project is using JDK8.
When IDE is running on JDK8, debugging works without problems.

It seems that when JAR is created in NetBeans running on JDK7, then classes from package com.javafx.main from JDK7 are packed into jar.
Comment 4 Lou Dasaro 2013-09-20 04:27:43 UTC
I am renaming this so it will have a more meaningful title when seen in a list.
"Cannot debug when IDE is running on JDK7 and FX Project uses JDK8"
Comment 5 alainvitry 2013-10-17 21:18:37 UTC
Pinging up, as this is still the case in 7.4 GA. Running instead of debugging works fine. Debugging seems to pick the wrong platform.
Comment 6 Roman Svitanic 2013-10-24 07:23:26 UTC
*** Bug 237579 has been marked as a duplicate of this bug. ***
Comment 7 Roman Svitanic 2013-11-18 10:47:25 UTC
Issue is not reproducible in the latest DEV build + JDK 8 b116. It seems that some issue in JavaFX packager has been fixed and it does not cause the problem with debugging anymore. Someone please verify whether the issue can't be reproduced or it it possible to reproduce it in some way. If you'll manage to reproduce behavior mentioned in this bug report, please reopen this issue and post steps how it can be reproduced in the latest dev builds with latest JDK8 build. Thanks!
Comment 8 Lou Dasaro 2013-12-21 06:33:44 UTC
Issue is not reproducible in the latest DEV build + JDK 8 b120.
Comment 9 Lou Dasaro 2013-12-21 07:00:20 UTC
Also verified works in 7.4-patch2