Bug 236185 - [74cat]NullPointerException at org.netbeans.modules.subversion.FileStatusCache.scanFolder
Summary: [74cat]NullPointerException at org.netbeans.modules.subversion.FileStatusCach...
Status: RESOLVED FIXED
Alias: None
Product: versioncontrol
Classification: Unclassified
Component: Subversion (show other bugs)
Version: 7.4
Hardware: All All
: P3 normal (vote)
Assignee: Ondrej Vrabec
URL:
Keywords:
: 236201 238066 239014 243022 (view as bug list)
Depends on:
Blocks:
 
Reported: 2013-09-20 11:42 UTC by muellermi
Modified: 2014-03-20 16:11 UTC (History)
4 users (show)

See Also:
Issue Type: DEFECT
Exception Reporter: 204030


Attachments
stacktrace (3.82 KB, text/plain)
2013-09-20 11:42 UTC, muellermi
Details

Note You need to log in before you can comment on or make changes to this bug.
Description muellermi 2013-09-20 11:42:28 UTC
Build: NetBeans IDE Dev (Build 201309191137)
VM: Java HotSpot(TM) 64-Bit Server VM, 24.0-b56, Java(TM) SE Runtime Environment, 1.7.0_40-b43
OS: Windows 7

User Comments:
muellermi: project dir deleted




Stacktrace: 
java.lang.NullPointerException
   at org.netbeans.modules.subversion.FileStatusCache.scanFolder(FileStatusCache.java:925)
   at org.netbeans.modules.subversion.FileStatusCache.getScannedFiles(FileStatusCache.java:849)
   at org.netbeans.modules.subversion.FileStatusCache.getStatus(FileStatusCache.java:418)
   at org.netbeans.modules.subversion.FileStatusCache.createMissingEntryFileInformation(FileStatusCache.java:1083)
   at org.netbeans.modules.subversion.FileStatusCache.createFileInformation(FileStatusCache.java:947)
   at org.netbeans.modules.subversion.FileStatusCache.refresh(FileStatusCache.java:597)
Comment 1 muellermi 2013-09-20 11:42:30 UTC
Created attachment 140291 [details]
stacktrace
Comment 2 Ondrej Vrabec 2013-09-20 12:15:14 UTC
probably a not managed file with null topmostManagedAncestor
Comment 3 Ondrej Vrabec 2013-09-20 12:16:14 UTC
fixed: core-main #137f7d38f43e
Comment 4 Ondrej Vrabec 2013-09-22 13:42:03 UTC
*** Bug 236201 has been marked as a duplicate of this bug. ***
Comment 5 Ondrej Vrabec 2013-11-07 07:40:43 UTC
*** Bug 238066 has been marked as a duplicate of this bug. ***
Comment 6 Ondrej Vrabec 2013-12-01 08:44:19 UTC
*** Bug 239014 has been marked as a duplicate of this bug. ***
Comment 7 Ondrej Vrabec 2014-03-20 16:11:55 UTC
*** Bug 243022 has been marked as a duplicate of this bug. ***