This Bugzilla instance is a read-only archive of historic NetBeans bug reports. To report a bug in NetBeans please follow the project's instructions for reporting issues.

Bug 236530 - NullPointerException at javax.swing.text.View.getStartOffset
Summary: NullPointerException at javax.swing.text.View.getStartOffset
Status: RESOLVED DUPLICATE of bug 232038
Alias: None
Product: editor
Classification: Unclassified
Component: Painting & Printing (show other bugs)
Version: 7.4
Hardware: PC Windows 7 x64
: P3 normal (vote)
Assignee: Miloslav Metelka
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-09-30 07:28 UTC by serras
Modified: 2013-11-12 15:11 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
Exception Reporter: 202722


Attachments
stacktrace (3.52 KB, text/plain)
2013-09-30 07:28 UTC, serras
Details
stacktrace (3.52 KB, text/plain)
2013-10-22 13:11 UTC, serras
Details

Note You need to log in before you can comment on or make changes to this bug.
Description serras 2013-09-30 07:28:03 UTC
Build: NetBeans IDE 7.4 Beta (Build 201307092200)
VM: Java HotSpot(TM) 64-Bit Server VM, 23.25-b01, Java(TM) SE Runtime Environment, 1.7.0_25-b16
OS: Windows 7

User Comments:
GUEST: just editing source code (deleting some lines actually)

GUEST: using find

serras: stopping debug of  an java ee web aplication deployed on tomcat.
when clicked on the editor this bug appeared.

Apparently it doesn't affect anything of my normal use

rekiem87: Editing java code




Stacktrace: 
java.lang.NullPointerException
   at javax.swing.text.View.getStartOffset(View.java:811)
   at org.netbeans.modules.editor.lib2.view.WrapInfoUpdater.breakView(WrapInfoUpdater.java:445)
   at org.netbeans.modules.editor.lib2.view.WrapInfoUpdater.initWrapInfo(WrapInfoUpdater.java:204)
   at org.netbeans.modules.editor.lib2.view.ParagraphViewChildren.buildWrapLines(ParagraphViewChildren.java:386)
   at org.netbeans.modules.editor.lib2.view.ParagraphViewChildren.updateLayout(ParagraphViewChildren.java:380)
   at org.netbeans.modules.editor.lib2.view.ParagraphView.updateLayoutAndScheduleRepaint(ParagraphView.java:277)
Comment 1 serras 2013-09-30 07:28:05 UTC
Created attachment 140636 [details]
stacktrace
Comment 2 serras 2013-09-30 07:35:40 UTC
One correction needed to restart netbeans to continue to work, since the exception appears every time I click on the editor or on a class file on the project explorer
Comment 3 Exceptions Reporter 2013-10-09 23:37:11 UTC
This bug already has 5 duplicates 
see http://statistics.netbeans.org/exceptions/detail.do?id=202722
Comment 4 serras 2013-10-22 13:11:39 UTC
Created attachment 141408 [details]
stacktrace

Paused on a breakpoint in JavaEE development with tomcat server.
When I clicked on the text editor gave ths exception.

Can't tell the steps to reproduce, since it seems a bit random.
Comment 5 Miloslav Metelka 2013-11-12 15:11:48 UTC

*** This bug has been marked as a duplicate of bug 232038 ***