This Bugzilla instance is a read-only archive of historic NetBeans bug reports. To report a bug in NetBeans please follow the project's instructions for reporting issues.

Bug 237747 - Throwable at org.netbeans.modules.editor.fold.FoldChildren.insertImpl
Summary: Throwable at org.netbeans.modules.editor.fold.FoldChildren.insertImpl
Status: RESOLVED FIXED
Alias: None
Product: editor
Classification: Unclassified
Component: Code folding (show other bugs)
Version: 8.0
Hardware: All All
: P3 normal (vote)
Assignee: Svata Dedic
URL:
Keywords:
: 237900 237947 (view as bug list)
Depends on:
Blocks:
 
Reported: 2013-10-29 11:06 UTC by Maksim Khramov
Modified: 2013-11-06 03:18 UTC (History)
24 users (show)

See Also:
Issue Type: DEFECT
Exception Reporter: 204886


Attachments
stacktrace (2.13 KB, text/plain)
2013-10-29 11:06 UTC, Maksim Khramov
Details
stacktrace (2.13 KB, text/plain)
2013-10-29 17:49 UTC, mmolda
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Maksim Khramov 2013-10-29 11:06:05 UTC
Build: NetBeans IDE Dev (Build 201310210001)
VM: Java HotSpot(TM) 64-Bit Server VM, 24.45-b08, Java(TM) SE Runtime Environment, 1.7.0_45-b18
OS: Windows 7

User Comments:
muellermi: Still whilst editing JSF page. After code completition.

brettryan: This is still a problem in latest DEV build.

muellermi: editing JSF page

GUEST: ???????

steve.clason: Reliably reproduced when wrapping a number, not a letter, with an html tag. After typing the leading tag, using the right arrow key to move the cursor past the number throws the error.

padraigdoran: new line

ouardisoft: Select tab

ouardisoft: Create into file

GUEST: s

GUEST: fdgdfg

muellermi: edit jsf

victork: IDE was on 'Start Page' tab.
Clicked on tab of one of project's files(Which has "Find' line opened in bottom) and exception occured.

GUEST: Editing source file

muellermi: edit jsf page

padraigdoran: undo/redo smarty tpl

GUEST: just editing a html file, but this dialog popup so frequently.

tboudreau: Throwing Throwable?!

I copied a line importing a css file and pasted it below the next line.

GUEST: This has been occuring while I'm developing CSS with SASS.  I also have several PHP a,d JS documents open.

Comment 1 Maksim Khramov 2013-10-29 11:06:10 UTC
Created attachment 141625 [details]
stacktrace
Comment 2 mmolda 2013-10-29 17:49:06 UTC
Created attachment 141652 [details]
stacktrace

Inserting <tr>and </tr> tags into many places in code.
Comment 3 Svata Dedic 2013-11-01 13:27:45 UTC
Folks, apologies to all - but I could not reproduce the defect; I took top 5 and tried to recreate the situation, but failed.

I have some changes, which may improve the situation, but the patch os written on blind and the data should not arrive in an inconsistent way to that point anyway, but if they do, the changeset will clean them up.

Please be patient, and if the committed change (again) does not help, and you happen to run into the same issue again, try to do the following:
* Undo.
* Save.
* try again (the last change or several ones). If the defect still happens,
* close the file (was saved already, do not save the latest change)
* reopen the file
* make the last change again, do not save. If you run into the issue, then PLEASE PLEASE do attach the saved file AND describe exactly what edits should be made. I would be most thankful to some reproduction steps that could allow me to pinpoint the place where the lookup hierarchy gets corrupted.

Feel free to reopen the defect should you have (more or less) reliable reproduction steps.

Fix attempted in changeset http://hg.netbeans.org/jet-main/rev/0261bbdc6222
Comment 4 Svata Dedic 2013-11-01 18:04:56 UTC
*** Bug 237900 has been marked as a duplicate of this bug. ***
Comment 5 Vladimir Riha 2013-11-04 13:41:03 UTC
*** Bug 237947 has been marked as a duplicate of this bug. ***
Comment 6 Quality Engineering 2013-11-06 03:18:23 UTC
Integrated into 'main-silver', will be available in build *201311060001* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)

Changeset: http://hg.netbeans.org/main-silver/rev/0261bbdc6222
User: Svata Dedic <sdedic@netbeans.org>
Log: #237747: additional compensation of possibly corrupted lookup hierarchy