This Bugzilla instance is a read-only archive of historic NetBeans bug reports. To report a bug in NetBeans please follow the project's instructions for reporting issues.

Bug 237926 - Actions assigned to Meta+EQUALS fire twice when keyboard shortcut invoked (e.g. "Zoom Text In")
Summary: Actions assigned to Meta+EQUALS fire twice when keyboard shortcut invoked (e....
Status: RESOLVED WONTFIX
Alias: None
Product: platform
Classification: Unclassified
Component: Actions (show other bugs)
Version: 7.4
Hardware: Macintosh Mac OS X
: P3 normal with 1 vote (vote)
Assignee: Jan Peska
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-11-04 00:12 UTC by ebakke
Modified: 2014-01-14 14:59 UTC (History)
0 users

See Also:
Issue Type: DEFECT
Exception Reporter:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description ebakke 2013-11-04 00:12:01 UTC
This is probably a MacOS-specific bug. It's easy to reproduce; just open up a source editor window and press Meta+EQUALS to zoom the text in. The text is rapidly zoomed in two steps instead of one (zoom back out again with Meta+MINUS, and you'll see that you're not back to the previous zoom factor like you would otherwise).

The problem is related to the Meta+EQUALS key combination, not to the Zoom Text In action. Any action assigned to this keyboard shortcut will have the same behavior (e.g. the "Start New Line" action will insert two lines instead of one if invoked via this keyboard shortcut). I've also confirmed the same behavior in my own NetBeans Platform application.

There was a related bug with the DELETE key on MacOS a while back [1], but its underlying JDK bug was fixed [2], backported to 7u40 [3], and closed, and I can no longer reproduce that particular bug (I'm running 1.7.0_45-b18). Hence I'm filing a new bug.

[1] http://netbeans.org/bugzilla/show_bug.cgi?id=219853
[2] http://bugs.sun.com/bugdatabase/view_bug.do?bug_id=8008366
[3] http://bugs.sun.com/bugdatabase/view_bug.do?bug_id=8014542

Product Version: NetBeans IDE 7.4 (Build 201310111528)
Java: 1.7.0_45; Java HotSpot(TM) 64-Bit Server VM 24.45-b08
Runtime: Java(TM) SE Runtime Environment 1.7.0_45-b18
System: Mac OS X version 10.9 running on x86_64; UTF-8; en_US (nb)
Comment 1 Jan Peska 2014-01-14 13:05:37 UTC
It is reproducible with JDK7, but I tried it with JDK8 b115 and it seems to be fixed. Can you please verify that? You can download latest JDK8 at https://jdk8.java.net/download.html

I'll close the issue as wontfix since it is most likely fixed JDK bug, but feel free to reopen it if you think otherwise.
Comment 2 ebakke 2014-01-14 14:59:41 UTC
I can confirm that the bug seems to be fixed on 1.8.0-ea; Java HotSpot(TM) 64-Bit Server VM 25.0-b59--it makes sense to close it. Thanks!