This Bugzilla instance is a read-only archive of historic NetBeans bug reports. To report a bug in NetBeans please follow the project's instructions for reporting issues.

Bug 238459 - AssertionError: Need to normalize /home1/NBP/Indicium_Plugins/WebsiteSearch/lib/Website//home1/NBP/Indicium_Plugins/WebsiteSearch/lib/Website/Search/Engine(class java.io.File) was /home1/NBP/Indicium_
Summary: AssertionError: Need to normalize /home1/NBP/Indicium_Plugins/WebsiteSearch/l...
Status: RESOLVED WORKSFORME
Alias: None
Product: platform
Classification: Unclassified
Component: Filesystems (show other bugs)
Version: 7.4
Hardware: All All
: P3 normal (vote)
Assignee: Jaroslav Havlin
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-11-16 14:58 UTC by Exceptions Reporter
Modified: 2013-11-18 08:20 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
Exception Reporter: 205335


Attachments
stacktrace (8.80 KB, text/plain)
2013-11-16 14:58 UTC, Exceptions Reporter
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Exceptions Reporter 2013-11-16 14:58:01 UTC
This bug was originally marked as duplicate of bug 235332, that is already resolved. This bug is still valid, so this seems to be another bug, but it might be related.

Build: NetBeans IDE 7.4 (Build 201310111528)
VM: Java HotSpot(TM) 64-Bit Server VM, 23.25-b01, Java(TM) SE Runtime Environment, 1.7.0_25-b15
OS: Linux

User Comments:
GUEST: editing php file

vriha: I can't really tell what caused it, I created HTML5 project and HTML5-Cordova project




Stacktrace: 
java.lang.AssertionError: Need to normalize /home1/NBP/Indicium_Plugins/WebsiteSearch/lib/Website//home1/NBP/Indicium_Plugins/WebsiteSearch/lib/Website/Search/Engine(class java.io.File) was /home1/NBP/Indicium_Plugins/WebsiteSearch/lib/Website/home1/NBP/Indicium_Plugins/WebsiteSearch/lib/Website/Search/Engine(class java.io.File)
   at org.openide.filesystems.FileUtil.assertNormalized(FileUtil.java:153)
   at org.openide.filesystems.FileUtil.toFile(FileUtil.java:829)
   at org.netbeans.modules.versioning.core.api.VCSFileProxy.createFileProxy(VCSFileProxy.java:168)
   at org.netbeans.modules.versioning.masterfs.FilesystemInterceptor.deletedExternally(FilesystemInterceptor.java:210)
   at org.netbeans.modules.masterfs.ProvidedExtensionsProxy$13.run(ProvidedExtensionsProxy.java:353)
   at org.netbeans.modules.masterfs.ProvidedExtensionsProxy.runCheckCode(ProvidedExtensionsProxy.java:493)
Comment 1 Exceptions Reporter 2013-11-16 14:58:04 UTC
Created attachment 142265 [details]
stacktrace
Comment 2 Ondrej Vrabec 2013-11-16 15:09:09 UTC
another cordova-fs wrong fileobject path
Comment 3 Jaroslav Havlin 2013-11-18 08:20:09 UTC
This bug should be already fixed (see bug 235332).
Please reopen this issue if you can reproduce the bug with
the latest development build. Thank you.