This Bugzilla instance is a read-only archive of historic NetBeans bug reports. To report a bug in NetBeans please follow the project's instructions for reporting issues.

Bug 238646 - Not able to add new Netbeans platform
Summary: Not able to add new Netbeans platform
Alias: None
Product: apisupport
Classification: Unclassified
Component: Project (show other bugs)
Version: 7.4
Hardware: PC Linux
: P1 normal (vote)
Assignee: Martin Kozeny
Depends on:
Reported: 2013-11-21 10:35 UTC by adithyank
Modified: 2013-11-21 14:30 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
Exception Reporter:

IDE log (53.02 KB, text/plain)
2013-11-21 10:35 UTC, adithyank
screenshot showing the disabled next/finish button while adding nb7.3 as a platform (43.34 KB, image/png)
2013-11-21 10:37 UTC, adithyank

Note You need to log in before you can comment on or make changes to this bug.
Description adithyank 2013-11-21 10:35:47 UTC
Product Version: NetBeans IDE 7.4 (Build 201310111528)
Updates: NetBeans IDE is updated to version NetBeans 7.4 Patch 1
Java: 1.7.0_45; Java HotSpot(TM) Client VM 24.45-b08
Runtime: Java(TM) SE Runtime Environment 1.7.0_45-b18
System: Linux version 2.6.32-358.23.2.el6.i686 running on i386; UTF-8; en_US (nb)
User directory: /root/.netbeans/7.4
Cache directory: /root/.cache/netbeans/7.4

1. For testing my nb plugin I tried to add nb 7.3 using tools -> netbeans platform menu.
2. In the window that came, I clicked "Add Platform"
3. In the new window, I clicked the directory where I have installed netbeans 7.3
4. The Next button is still in disabled condition.

So, I could not test my plugin in nb 7.3
Comment 1 adithyank 2013-11-21 10:35:51 UTC
Created attachment 142436 [details]
IDE log
Comment 2 adithyank 2013-11-21 10:37:43 UTC
Attaching the screenshot showing the disabled next/finish button while adding nb7.3 as a platform
Comment 3 adithyank 2013-11-21 10:37:50 UTC
Created attachment 142437 [details]
screenshot showing the disabled next/finish button while adding nb7.3 as a platform
Comment 4 Jiri Kovalsky 2013-11-21 11:59:29 UTC
This works fine for me. Did you launch the IDE as "root" or as "adi" user?
Comment 5 adithyank 2013-11-21 13:07:23 UTC
I am always using root user for launching the IDE
Comment 6 Martin Kozeny 2013-11-21 13:54:09 UTC
It works also for me. I'll look at the condition under which is Next button disabled.
Comment 7 Martin Kozeny 2013-11-21 14:11:39 UTC
Isn't your platform dir somehow corrupted?
Comment 8 adithyank 2013-11-21 14:17:52 UTC
I checked the code. I discovered that the code expects installation-dir/platform/core/core.jar.

If core.jar is available, then it decides that dir as platform dir.

Then, I checked in my installation directory of nb 7.3. This jar is not available in the specified sub-directory.

Then, I tried to add nb 7.2 installation (which contains this core.jar). It succeeded.

I am not sure how the core.jar disappeared from the nb 7.3 directory.

If my above inference from the code is correct, then you can close this issue with some comment!

Sorry for the inconvenience
Comment 9 Martin Kozeny 2013-11-21 14:30:14 UTC
Ok. Feel free to reopen if problem persists. Closing as INVALID.