This Bugzilla instance is a read-only archive of historic NetBeans bug reports. To report a bug in NetBeans please follow the project's instructions for reporting issues.

Bug 239133 - Allow Open Resources to work for "close" child Maven projects
Summary: Allow Open Resources to work for "close" child Maven projects
Status: RESOLVED DUPLICATE of bug 228560
Alias: None
Product: projects
Classification: Unclassified
Component: Maven (show other bugs)
Version: 7.4
Hardware: PC Windows 7
: P3 normal (vote)
Assignee: Milos Kleint
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-12-04 22:06 UTC by satory
Modified: 2013-12-05 09:01 UTC (History)
0 users

See Also:
Issue Type: ENHANCEMENT
Exception Reporter:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description satory 2013-12-04 22:06:11 UTC
[ JDK VERSION : 1.7.0_25 ]

I have a fairly large maven project that is split into a lot of smaller
projects in a somewhat simple hierarchal manor...

The problem I have is that I cant/dont want to open too many projects in the
IDE at once, and yet I cannot easily search for a class by using the "GO To
Type" Dialog.  

I have seen this plugin[1] which provides an integrated view, which isnt what I
want, due the the number of child projects that I have, but this plugin does
allow me to use the Go To Type dialog to search all the projects.

Is there any way that this functionality to use the Go To Type dialog for all
child projects in an open project?

[1]: https://blogs.oracle.com/geertjan/entry/maven_integrated_view_for_netbeans
Comment 1 Milos Kleint 2013-12-05 09:01:15 UTC
duplicate of issue 228560 I think

*** This bug has been marked as a duplicate of bug 228560 ***