This Bugzilla instance is a read-only archive of historic NetBeans bug reports. To report a bug in NetBeans please follow the project's instructions for reporting issues.

Bug 239537 - "Identation Guide Lines" works badly in C/C++ files
Summary: "Identation Guide Lines" works badly in C/C++ files
Status: RESOLVED DUPLICATE of bug 182513
Alias: None
Product: editor
Classification: Unclassified
Component: Formatting & Indentation (show other bugs)
Version: 8.0
Hardware: PC Windows 7
: P3 normal (vote)
Assignee: Dusan Balek
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-12-16 18:43 UTC by soldatov
Modified: 2014-01-15 15:33 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
Exception Reporter:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description soldatov 2013-12-16 18:43:25 UTC
Code:
int main(int argc, char** argv) {
    if (1) {
        if (1) {
            if (1) {
                if (1) {
                    if (1) {
                        ;
                    }
                }
            }
        }
    }
    return 0;
}

Expected behavior: All 5 'if' has identation guide lines
Real: 2 'if' has gray lines
Comment 1 Alexander Simon 2013-12-17 07:41:46 UTC
Investigation:
Editor uses SimpleValueNames.SPACES_PER_TAB property for indent size.
Should use SimpleValueNames.INDENT_SHIFT_WIDTH.
See change set in the bug #182513

Reassign to evaluation.
Comment 2 Dusan Balek 2014-01-15 15:33:29 UTC
Should be already fixed.

*** This bug has been marked as a duplicate of bug 182513 ***