Bug 239817 - [80cat] JSF: no templating
Summary: [80cat] JSF: no templating
Status: RESOLVED FIXED
Alias: None
Product: javaee
Classification: Unclassified
Component: JSF (show other bugs)
Version: 8.0
Hardware: All All
: P2 normal (vote)
Assignee: Martin Fousek
URL:
Keywords:
: 239911 (view as bug list)
Depends on:
Blocks:
 
Reported: 2013-12-26 21:58 UTC by muellermi
Modified: 2014-01-06 05:36 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
Exception Reporter:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description muellermi 2013-12-26 21:58:01 UTC
Product Version = NetBeans IDE Dev (Build 201312250002)
Operating System = Windows 8 version 6.2 running on amd64
Java; VM; Vendor = 1.8.0-ea
Runtime = Java HotSpot(TM) 64-Bit Server VM 25.0-b61

- Create a web oproject with JSF
- Choose New, Other, JSF, <any subfolder>, <any type>

--> NB does not create the requested file from the template, but adds a template (.flt) file to the project
Comment 1 muellermi 2013-12-26 22:05:36 UTC
typo: .ftl file
Comment 2 Martin Fousek 2014-01-02 07:36:25 UTC
*** Bug 239911 has been marked as a duplicate of this bug. ***
Comment 3 Martin Fousek 2014-01-02 07:39:17 UTC
The issue is that the JSF folder has subcategories. These categories should be visible only within templates, to customize them. They are part of the JSF Pages from EC feature so they shouldn't be displayed here.
Comment 4 Martin Fousek 2014-01-02 08:28:30 UTC
Ok, should be fixed in web-main #1e22ce618119.

You are able to customize these templates via Tools/Templates or within the JSF Pages from Entity Classes wizard but the category doesn't exist in the New File wizard any more.
Comment 5 Quality Engineering 2014-01-03 02:50:54 UTC
Integrated into 'main-silver', will be available in build *201401030002* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)

Changeset: http://hg.netbeans.org/main-silver/rev/1e22ce618119
User: Martin Fousek <marfous@netbeans.org>
Log: #239817 - [80cat] JSF: no templating
Comment 6 muellermi 2014-01-03 23:16:14 UTC
Now the buggy subfolders disappeared.

But, in one of them I discovered "message bundle". Create a message bundle had been available in an older version of NB. Where is it gone now?
Comment 7 Martin Fousek 2014-01-06 05:36:28 UTC
(In reply to muellermi from comment #6)
> Now the buggy subfolders disappeared.
> 
> But, in one of them I discovered "message bundle". Create a message bundle
> had been available in an older version of NB. Where is it gone now?

You should be still able to create message bundle: Other -> Properties file
This will create you the bundle of your name.