Bug 239849 - Replicated license template after refactoring
Summary: Replicated license template after refactoring
Status: RESOLVED FIXED
Alias: None
Product: java
Classification: Unclassified
Component: Source (show other bugs)
Version: 8.0
Hardware: PC All
: P2 normal (vote)
Assignee: Svata Dedic
URL:
Keywords:
: 239442 240012 240293 241055 241584 241800 242083 (view as bug list)
Depends on:
Blocks:
 
Reported: 2013-12-29 08:15 UTC by ceklock
Modified: 2014-02-19 09:50 UTC (History)
9 users (show)

See Also:
Issue Type: DEFECT
Exception Reporter:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description ceklock 2013-12-29 08:15:56 UTC
[ BUILD # : 201312280002 ]
[ JDK VERSION : 1.7.0_45 ]

STEPS:
   * Make sure you have a not-empty Java license template;
   * Create a new Java class;
   * Check if the text of the license template is present;
   * Do a rename refactoring;

ACTUAL:
   license template is replicated.

EXPECTED:
   no changes in license template when refactoring is done.
Comment 1 _ gtzabari 2013-12-31 16:19:57 UTC
I've got the same problem. Is this issue assigned to the right component?
Comment 2 Ralph Ruijs 2014-01-07 10:12:10 UTC
Looks to be caused by http://hg.netbeans.org/jet-main/rev/f337e7fcf46f, reassigning.
Comment 3 Ralph Ruijs 2014-01-07 13:33:26 UTC
*** Bug 239442 has been marked as a duplicate of this bug. ***
Comment 4 Ralph Ruijs 2014-01-09 09:53:15 UTC
*** Bug 240012 has been marked as a duplicate of this bug. ***
Comment 5 Jiri Prox 2014-01-13 11:57:11 UTC
*** Bug 240293 has been marked as a duplicate of this bug. ***
Comment 6 Quality Engineering 2014-01-15 02:40:36 UTC
Integrated into 'main-silver', will be available in build *201401150002* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)

Changeset: http://hg.netbeans.org/main-silver/rev/d0049fb977c2
User: Svata Dedic <sdedic@netbeans.org>
Log: #239849: avoid replication of init comment. Template initial comment is preserved unless the created CU contains its own one
Comment 7 Svata Dedic 2014-01-20 09:25:03 UTC
Was fixed in jet-main#d0049fb977c2
Comment 8 Ralph Ruijs 2014-01-28 12:17:38 UTC
*** Bug 241055 has been marked as a duplicate of this bug. ***
Comment 9 Jiri Prox 2014-02-10 08:56:12 UTC
*** Bug 241584 has been marked as a duplicate of this bug. ***
Comment 10 Marian Mirilovic 2014-02-13 09:36:22 UTC
*** Bug 241800 has been marked as a duplicate of this bug. ***
Comment 11 Jiri Prox 2014-02-19 09:50:18 UTC
*** Bug 242083 has been marked as a duplicate of this bug. ***