This Bugzilla instance is a read-only archive of historic NetBeans bug reports. To report a bug in NetBeans please follow the project's instructions for reporting issues.

Bug 242108 - AssertionError: Unexpected tree: pool.<IOException>await() with kind: METHOD_INVOCATION within: pool.<IOException>await() with kind: METHOD_INVOCATION
Summary: AssertionError: Unexpected tree: pool.<IOException>await() with kind: METHOD_...
Status: RESOLVED FIXED
Alias: None
Product: java
Classification: Unclassified
Component: Compiler (show other bugs)
Version: 8.0
Hardware: All All
: P3 normal (vote)
Assignee: Dusan Balek
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-02-19 16:40 UTC by almson
Modified: 2015-03-03 04:19 UTC (History)
12 users (show)

See Also:
Issue Type: DEFECT
Exception Reporter: 206974


Attachments
stacktrace (2.43 KB, text/plain)
2014-02-19 16:40 UTC, almson
Details
stacktrace (2.44 KB, text/plain)
2014-02-23 11:31 UTC, rudyment
Details
stacktrace (2.44 KB, text/plain)
2014-02-23 11:34 UTC, rudyment
Details
stacktrace (2.43 KB, text/plain)
2014-04-06 02:25 UTC, misterm
Details
stacktrace (2.43 KB, text/plain)
2014-04-06 02:28 UTC, misterm
Details
stacktrace (4.12 KB, text/plain)
2014-04-06 02:31 UTC, misterm
Details
stacktrace (2.43 KB, text/plain)
2015-02-25 17:33 UTC, theshadow27
Details
stacktrace (2.43 KB, text/plain)
2015-02-25 18:45 UTC, theshadow27
Details
stacktrace (2.43 KB, text/plain)
2015-02-25 18:48 UTC, theshadow27
Details
test case for replicating the issue (1.00 KB, text/plain)
2015-02-25 19:12 UTC, theshadow27
Details
Issue242108.dump (5.65 KB, text/plain)
2015-02-25 19:15 UTC, theshadow27
Details

Note You need to log in before you can comment on or make changes to this bug.
Description almson 2014-02-19 16:40:44 UTC
Build: NetBeans IDE 8.0 Beta (Build 201401141042)
VM: Java HotSpot(TM) 64-Bit Server VM, 25.0-b65, Java(TM) SE Runtime Environment, 1.8.0-ea-b123
OS: Windows 8

User Comments:
almson: Just trying to type in the Editor.

The await method is a little odd, it looks like:

<T extends Exception> public void await() throws T {...}

GUEST: <Please provide a description of the problem or the steps to reproduce>
well, I was trying to change the color of the identifier in the Tools - in the Color and Fonts tab, and it started to crush .... lolz

gtzabari: Deleted line in editor. Exception thrown.




Stacktrace: 
java.lang.AssertionError: Unexpected tree: pool.<IOException>await() with kind: METHOD_INVOCATION within: pool.<IOException>await() with kind: METHOD_INVOCATION
   at com.sun.tools.javac.util.Assert.error(Assert.java:133)
   at com.sun.tools.javac.comp.Attr$TypeAnnotationsValidator.validateAnnotatedType(Attr.java:4800)
   at com.sun.tools.javac.comp.Attr$TypeAnnotationsValidator.visitVarDef(Attr.java:4644)
   at com.sun.tools.javac.tree.JCTree$JCVariableDecl.accept(JCTree.java:852)
   at com.sun.tools.javac.tree.TreeScanner.scan(TreeScanner.java:49)
   at com.sun.tools.javac.comp.Attr$TypeAnnotationsValidator.visitClassDef(Attr.java:4695)
Comment 1 almson 2014-02-19 16:40:47 UTC
Created attachment 145408 [details]
stacktrace
Comment 2 Dusan Balek 2014-02-20 10:30:15 UTC
Extremely strange - seems that AST contains a variable declaration which type is a method invocation. Do you have a reproducible test case? Could you please attach the generated dump file to the issue? Is your project configured to use any annotation processor? Thanks.
Comment 3 rudyment 2014-02-23 11:31:46 UTC
Created attachment 145509 [details]
stacktrace

Error occurred during modifikation of the file while two files were compared by Diff to...
Comment 4 rudyment 2014-02-23 11:34:46 UTC
Created attachment 145510 [details]
stacktrace

Error occured while clicking at the right file from two files compared by Diff to
Comment 5 misterm 2014-04-06 02:25:38 UTC
Created attachment 146575 [details]
stacktrace

.
Comment 6 misterm 2014-04-06 02:28:38 UTC
Created attachment 146576 [details]
stacktrace

.
Comment 7 misterm 2014-04-06 02:31:37 UTC
Created attachment 146577 [details]
stacktrace

.
Comment 8 theshadow27 2015-02-25 17:33:55 UTC
Created attachment 152222 [details]
stacktrace

No idea, was set to silent reporting
Comment 9 theshadow27 2015-02-25 18:45:55 UTC
Created attachment 152225 [details]
stacktrace

Within a class, typed "Psi" + tab (expand to "public static interface", then typed "LDIF " then command+\ (by accident before typing the '{' bracket)
Comment 10 theshadow27 2015-02-25 18:48:55 UTC
Created attachment 152226 [details]
stacktrace

Replicated problem working on a test case...
Comment 11 theshadow27 2015-02-25 19:12:41 UTC
Created attachment 152227 [details]
test case for replicating the issue

Test case procedure: 
1) Open the file
2) Type 'e' where indicated by the comment in the first line of the class
Comment 12 theshadow27 2015-02-25 19:15:38 UTC
Created attachment 152228 [details]
Issue242108.dump

Dump from the IDE when running the test case
Comment 13 Dusan Balek 2015-02-26 14:04:51 UTC
Thanks for the reproducible test case.
Comment 15 Quality Engineering 2015-03-03 04:19:28 UTC
Integrated into 'main-silver', will be available in build *201503030001* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)

Changeset: http://hg.netbeans.org/main-silver/rev/ba19583f37aa
User: Dusan Balek <dbalek@netbeans.org>
Log: Issues #242108, #250685, and #250701 - fixed.