This Bugzilla instance is a read-only archive of historic NetBeans bug reports. To report a bug in NetBeans please follow the project's instructions for reporting issues.

Bug 242330 - OutOfMemoryError: GC overhead limit exceeded
Summary: OutOfMemoryError: GC overhead limit exceeded
Status: RESOLVED DUPLICATE of bug 238953
Alias: None
Product: platform
Classification: Unclassified
Component: Quick Search (show other bugs)
Version: 7.4
Hardware: All All
: P3 normal (vote)
Assignee: Jaroslav Havlin
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-02-25 16:41 UTC by jasondonmoyer
Modified: 2014-02-27 07:52 UTC (History)
0 users

See Also:
Issue Type: DEFECT
Exception Reporter: 207293


Attachments
stacktrace (2.55 KB, text/plain)
2014-02-25 16:41 UTC, jasondonmoyer
Details

Note You need to log in before you can comment on or make changes to this bug.
Description jasondonmoyer 2014-02-25 16:41:35 UTC
Build: NetBeans IDE 7.4 (Build 201310111528)
VM: Java HotSpot(TM) 64-Bit Server VM, 24.51-b03, Java(TM) SE Runtime Environment, 1.7.0_51-b13
OS: Windows 7

User Comments:
jasondonmoyer: attempting to modify a spring xml file

GUEST: Some kind of memory leak.  Had to rebook machine.  Not sure if it is netbeans




Stacktrace: 
java.lang.OutOfMemoryError: GC overhead limit exceeded
   at java.util.Arrays.copyOfRange(Arrays.java:2694)
   at java.lang.String.<init>(String.java:203)
   at java.lang.StringBuilder.toString(StringBuilder.java:405)
   at org.netbeans.modules.search.TextDetail$DetailNode.getFullDesc(TextDetail.java:881)
   at org.netbeans.modules.search.TextDetail$DetailNode.<init>(TextDetail.java:516)
   at org.netbeans.modules.search.MatchingObject$DetailsChildren.createNodes(MatchingObject.java:1076)
Comment 1 jasondonmoyer 2014-02-25 16:41:37 UTC
Created attachment 145574 [details]
stacktrace
Comment 2 Jaroslav Havlin 2014-02-27 07:52:08 UTC
> User Comments:
> jasondonmoyer: attempting to modify a spring xml file
Report duplicate 714302 moved to bug 239570.

> GUEST: Some kind of memory leak.  Had to rebook machine.  Not sure if it is
> netbeans
Report duplicate 710574 seems to be the same problem as bug 238953.

Thank you for reporting.

*** This bug has been marked as a duplicate of bug 238953 ***