This Bugzilla instance is a read-only archive of historic NetBeans bug reports. To report a bug in NetBeans please follow the project's instructions for reporting issues.

Bug 242492 - Systematic Java Heap space exception at start
Summary: Systematic Java Heap space exception at start
Status: RESOLVED DUPLICATE of bug 242375
Alias: None
Product: editor
Classification: Unclassified
Component: Parsing & Indexing (show other bugs)
Version: 8.0
Hardware: PC Windows 7
: P2 normal (vote)
Assignee: Tomas Zezula
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-03-02 14:08 UTC by herve66
Modified: 2014-03-06 08:00 UTC (History)
0 users

See Also:
Issue Type: DEFECT
Exception Reporter:


Attachments
The IDE log retrieved by the IDE at each start (52.37 KB, application/octet-stream)
2014-03-02 14:08 UTC, herve66
Details
Netbeans project + build.xml file (42.35 KB, application/zip)
2014-03-05 00:49 UTC, herve66
Details

Note You need to log in before you can comment on or make changes to this bug.
Description herve66 2014-03-02 14:08:43 UTC
Created attachment 145699 [details]
The IDE log retrieved by the IDE at each start

Since NetBeans 8.0, I have a systematic Java heap space exception when starting Netbeans. I use Netbeans with Java 8 RC (b129), but I used the same JVM for 7.4 without any problem.

Note that I even have this problem if I previously closed all projects in the IDE before closing (so if I open NetBeans without any project to open).
Comment 1 herve66 2014-03-02 14:15:00 UTC
I did not change the defaults options which are:
netbeans_default_options="-J-client -J-Xss2m -J-Xms32m -J-XX:PermSize=32m -J-Dapple.laf.useScreenMenuBar=true -J-Dapple.awt.graphics.UseQuartz=true -J-Dsun.java2d.noddraw=true -J-Dsun.java2d.dpiaware=true -J-Dsun.zip.disableMemoryMapping=true"

And I have 16 Go of physical memory available on my PC.
Comment 2 Tomas Hurka 2014-03-03 07:54:26 UTC
To diagnose it, we need a heap dump from java.lang.OutOfMemoryError. Please upload zipped heap dump (C:\Users\Herve\AppData\Roaming\NetBeans\8.0rc1\var\log\heapdump.hprof.old) here: <http://deadlock.netbeans.org/job/upload/build>. Thanks.
Comment 3 herve66 2014-03-03 23:36:13 UTC
OK, I'm doing it right now. It seems that it fails with this problem once in 2 or 3 start attempts, not all (however, yesterday, it seemed to fail all the time). OK, done, the ID for the zipped dump is Bug242492.
Comment 4 Tomas Hurka 2014-03-04 10:04:36 UTC
java.util.ArrayList#15517 has retained size 460M. It has 52,500,000 items, full of duplicated URLs. This array list is held from org.netbeans.modules.parsing.impl.indexing.Util.fastTransitiveDeps() in "RepositoryUpdater.worker" thread. Reassigning to editor/parsing for further evaluation.
Comment 5 Tomas Zezula 2014-03-04 12:20:50 UTC
Caused by cyclic dependencies in projects.

*** This bug has been marked as a duplicate of bug 242375 ***
Comment 6 herve66 2014-03-04 12:30:43 UTC
I opened only one Netbeans project, and it does not depend on other projects. Is there something I can do to fix this on my side?
Comment 7 Tomas Zezula 2014-03-04 12:34:42 UTC
If you can send me or attach the project or at least nbproject folder it will help.
Thanks!
Comment 8 herve66 2014-03-05 00:49:43 UTC
Created attachment 145770 [details]
Netbeans project + build.xml file

The Netbeans project + build.xml file for the project. There is only this project when I open Netbeans, and it has no dependencies I know of. The full project is at: https://sourceforge.net/p/j661/code/HEAD/tree/j661/trunk/.

Thanks,

Herve
Comment 9 Tomas Zezula 2014-03-05 08:46:51 UTC
Thanks!
Comment 10 herve66 2014-03-06 00:53:46 UTC
Do you want me to test on my project it on the last nightly build? I look on the parent bug and it looks as the fix is in trunk.
Comment 11 Tomas Zezula 2014-03-06 08:00:09 UTC
As far as I know the QA (Jirka Prox) already did verification on the https://sourceforge.net/p/j661/code/HEAD/tree/j661/trunk/ sources.