This Bugzilla instance is a read-only archive of historic NetBeans bug reports. To report a bug in NetBeans please follow the project's instructions for reporting issues.

Bug 245256 - git revision tree/graph
Summary: git revision tree/graph
Status: RESOLVED DUPLICATE of bug 221662
Alias: None
Product: versioncontrol
Classification: Unclassified
Component: Git (show other bugs)
Version: 8.0
Hardware: PC Linux
: P3 normal (vote)
Assignee: Ondrej Vrabec
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-06-26 11:37 UTC by xkr
Modified: 2014-06-26 11:43 UTC (History)
1 user (show)

See Also:
Issue Type: ENHANCEMENT
Exception Reporter:


Attachments
IDE log (38.98 KB, text/plain)
2014-06-26 11:38 UTC, xkr
Details
git revision graph example on the left side of the picture (41.66 KB, image/png)
2014-06-26 11:43 UTC, xkr
Details

Note You need to log in before you can comment on or make changes to this bug.
Description xkr 2014-06-26 11:37:57 UTC
Product Version = NetBeans IDE 8.0 (Build 201403101706)
Operating System = Linux version 3.11.10-11-desktop running on amd64
Java; VM; Vendor = 1.7.0_51
Runtime = OpenJDK 64-Bit Server VM 24.45-b08

In netbeans git support I am missing graphical revision tree/graph which is present for example in ideaIDE or gitk. It shows commits and dependencies between branches.
It shall be possible to do merges, cherry pick, ... in the revision tree/graph directly by right click.

I will attach screenshot of "gitk" utility which on the left has the revision graph as an example of revision graph.
Comment 1 xkr 2014-06-26 11:38:01 UTC
Created attachment 147784 [details]
IDE log
Comment 2 Ondrej Vrabec 2014-06-26 11:40:30 UTC

*** This bug has been marked as a duplicate of bug 221662 ***
Comment 3 xkr 2014-06-26 11:43:22 UTC
Created attachment 147785 [details]
git revision graph example on the left side of the picture

Left side of the picture contains selectable revision graph, on the right side I see information about the commit. I can do merges, diffs, tags, cherry pick, ... with right click on the revision graph. I envision this nice graphical feature in netbeans.