This Bugzilla instance is a read-only archive of historic NetBeans bug reports. To report a bug in NetBeans please follow the project's instructions for reporting issues.

Bug 246431 - Cannot run Java Web application on Linux on WildFly
Summary: Cannot run Java Web application on Linux on WildFly
Alias: None
Product: serverplugins
Classification: Unclassified
Component: WildFly (show other bugs)
Version: 8.0.1
Hardware: PC Linux
: P1 normal (vote)
Assignee: ehsavoie
Keywords: RELNOTE
Depends on:
Reported: 2014-08-13 11:40 UTC by Vladimir Riha
Modified: 2014-08-13 14:40 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
Exception Reporter:

Wildfly server log (63.11 KB, text/plain)
2014-08-13 11:40 UTC, Vladimir Riha
IDE log (62.83 KB, text/plain)
2014-08-13 11:41 UTC, Vladimir Riha
sample project (18.85 KB, application/zip)
2014-08-13 11:45 UTC, Vladimir Riha

Note You need to log in before you can comment on or make changes to this bug.
Description Vladimir Riha 2014-08-13 11:40:48 UTC
Created attachment 148678 [details]
Wildfly server log

Please try to:
 - add WildFly server to NetBeans (WildFly 8.1 Final)
 - in NetBeans, create a new Java Web project, all default and set it to run on Wildfly
 - right click on project and select Run

=> action fails, output tab contains (server log attached)

Initial deploying WebApplication15 to /home/vriha/wildfly-8.1.0.Final/standalone/deployments/WebApplication15.war
Completed initial distribution of WebApplication15
Deploying /home/vriha/wildfly-8.1.0.Final/standalone/deployments/WebApplication15.war
{"JBAS014771: Services with missing/unavailable dependencies" => [" is missing []"]}
/home/vriha/NetBeansProjects/WebApplication15/nbproject/build-impl.xml:1045: The module has not been deployed.
See the server log for details.
BUILD FAILED (total time: 4 seconds)

If I checked Wildfly Application Server -> Application -> Web Applications in Services window, the WebApplication15 is present with a little green triangle icon over it. If I try to open URL http://localhost:8080/WebApplication15/index.html in browser, I get 404 Not found

I'm not very familiar with Wildfly, I find this issue when I was trying to verify issue 245240. The same steps work fine on Windows 7 for me.

Product Version: NetBeans IDE 8.0.1 RC1 (Build 201408122300)
Java: 1.8.0_11; Java HotSpot(TM) Client VM 25.11-b03
Runtime: Java(TM) SE Runtime Environment 1.8.0_11-b12
System: Linux version 3.13.0-32-generic running on i386; UTF-8; en_US (nb)
Comment 1 Vladimir Riha 2014-08-13 11:41:14 UTC
Created attachment 148679 [details]
IDE log
Comment 2 Vladimir Riha 2014-08-13 11:45:14 UTC
Created attachment 148680 [details]
sample project

Here's archive of the project I tried to run
Comment 3 ehsavoie 2014-08-13 11:46:18 UTC
Looks like you have some issue with your Hornetq which prevents WildFly from deploying your war: 
56) HQ222010: Critical IO Error, shutting down the server. file=AIOSequentialFile:/home/vriha/wildfly-8.1.0.Final/standalone/data/messagingjournal/hornetq-data-1.hq.tmp, message=Can't open file: HornetQException[errorType=NATIVE_ERROR_CANT_OPEN_CLOSE_FILE message=Can't open file]

I think you will have to clean your WildFly installation
Comment 5 Vladimir Riha 2014-08-13 11:57:30 UTC
Thanks, I'll try it. If that's the case, I think RELNOTE would be useful here.
Comment 6 Vladimir Riha 2014-08-13 12:05:37 UTC
The links mention to configure

 <subsystem xmlns="urn:jboss:domain:messaging:1.1">

Do you have any idea where to put it? I tried file [serverFolder]/domain/configuration/domain.xml:

            <subsystem xmlns="urn:jboss:domain:messaging:2.0">

But no change, still the same problem. The jboss forum link mentions having wildfly in encrypted partition could be issue. I have encrypted home folder so I moved it to /var/www but I'm still getting the same problem.
Comment 7 Jiri Kovalsky 2014-08-13 12:06:56 UTC
Product Version: NetBeans IDE 8.0.1 RC1 (Build 201408122300)
Java: 1.8.0_05; Java HotSpot(TM) 64-Bit Server VM 25.5-b02
Runtime: Java(TM) SE Runtime Environment 1.8.0_05-b13
System: Linux version 3.13.0-24-generic running on amd64; UTF-8; en_US (nb)
Application Server: WildFly 8.1.0.Final "Kenny"

Works fine for me.
Comment 8 ehsavoie 2014-08-13 12:09:42 UTC
1/in standalone-full.xml if you are using the default config from the plugin.
The "edit configuration" on the server should get you there.
2/ domain mode is not supported by the plugin as part of it relies on the deployment scanner which doesn't work (for good reasons) with domain mode
Comment 9 Vladimir Riha 2014-08-13 12:19:19 UTC
Thank you Emmanuel, that does the trick. 

I propose a RELNOTE for this one:

Description: Web application fails to run on WildFly server on Linux due to encrypted partition

Workaround: Right click on WildFly server in Services, select Edit Configuration and paste <journal-type>NIO</journal-type> right below <hornetq-server> and restart the server.
Comment 10 ehsavoie 2014-08-13 12:27:37 UTC
Hum what do you mean by RELNOTE ?
Comment 11 Vladimir Riha 2014-08-13 12:32:10 UTC
That it should be mentioned in Release Notes page, like [1]. Don't worry, it is not your responsibility to "place" it there ;) 

Comment 12 Kenneth Ganfield 2014-08-13 13:20:00 UTC
added to release notes
Comment 13 Vladimir Riha 2014-08-13 14:40:43 UTC
Thank you, Ken