This Bugzilla instance is a read-only archive of historic NetBeans bug reports. To report a bug in NetBeans please follow the project's instructions for reporting issues.

Bug 247295 - NullPointerException at org.openide.filesystems.FileUtil.createFolder
Summary: NullPointerException at org.openide.filesystems.FileUtil.createFolder
Status: NEW
Alias: None
Product: platform
Classification: Unclassified
Component: Filesystems (show other bugs)
Version: 8.0
Hardware: All All
: P3 normal (vote)
Assignee: Jaroslav Havlin
Depends on:
Reported: 2014-09-19 09:24 UTC by pbradley
Modified: 2014-12-12 17:50 UTC (History)
0 users

See Also:
Issue Type: DEFECT
Exception Reporter: 212026

stacktrace (1.29 KB, text/plain)
2014-09-19 09:24 UTC, pbradley

Note You need to log in before you can comment on or make changes to this bug.
Description pbradley 2014-09-19 09:24:36 UTC
Build: NetBeans IDE 8.0.1 (Build 201408251540)
VM: Java HotSpot(TM) Client VM, 25.11-b03, Java(TM) SE Runtime Environment, 1.8.0_11-b12
OS: Windows 7

User Comments:
pbradley: I copied various netbeans projects from my local drive to a remote "My Documents" folder so that my projects would be stored in 

\\MYSERVER\\Users$\MyUserName\My Documents\projects

When I tried to open projects in this folder, they just appeared as regular folders, that is, Netbeans did not recognise them as Netbeans projects. To troubleshoot, I selected a project and removed any netbeans artifacts from it leaving only the src and lib folders. I then created a new Java project with the existing sources. This resulted in the NPE in the report.

   at org.openide.filesystems.FileUtil.createFolder(
   at org.openide.loaders.TemplateWizard$InstantiatingIteratorBridge.instantiate(
   at org.openide.loaders.TemplateWizard.handleInstantiate(
   at org.openide.loaders.TemplateWizard.instantiateNewObjects(
Comment 1 pbradley 2014-09-19 09:24:38 UTC
Created attachment 149363 [details]
Comment 2 pbradley 2014-09-19 09:29:45 UTC
As an additional check, I just tried creating a completely new project in folder 

\\MYSERVER\Users$\MyUserName\My Documents\NetBeansProjects

I get an error saying

Project Folder is not a valid path.
Comment 3 Jaroslav Havlin 2014-12-12 17:50:49 UTC
Do you need to authenticate to the remote server (is some password required to access it)?
If you map the remote folder to some drive, does it work?
(I'm very sorry for replying so late.)