This Bugzilla instance is a read-only archive of historic NetBeans bug reports. To report a bug in NetBeans please follow the project's instructions for reporting issues.

Bug 247860 - NullPointerException at org.netbeans.JarClassLoader$1DelayedManifest.getAttributes
Summary: NullPointerException at org.netbeans.JarClassLoader$1DelayedManifest.getAttri...
Status: RESOLVED FIXED
Alias: None
Product: platform
Classification: Unclassified
Component: Module System (show other bugs)
Version: 8.1
Hardware: All All
: P3 normal (vote)
Assignee: Jaroslav Tulach
URL:
Keywords:
Depends on: 247795
Blocks:
  Show dependency tree
 
Reported: 2014-10-10 11:21 UTC by Petr Hejl
Modified: 2014-10-29 11:42 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
Exception Reporter: 212628


Attachments
stacktrace (4.05 KB, text/plain)
2014-10-10 11:21 UTC, Petr Hejl
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Petr Hejl 2014-10-10 11:21:42 UTC
Build: NetBeans IDE Dev (Build 20141010-179a8aac5a0f)
VM: Java HotSpot(TM) 64-Bit Server VM, 25.5-b02, Java(TM) SE Runtime Environment, 1.8.0_05-b13
OS: Linux

User Comments:
phejl: Creating EAR project.




Stacktrace: 
java.lang.NullPointerException
   at org.netbeans.JarClassLoader$1DelayedManifest.getAttributes(JarClassLoader.java:284)
   at org.netbeans.PackageAttrsCache.extractFromManifest(PackageAttrsCache.java:153)
   at org.netbeans.PackageAttrsCache.findImpl(PackageAttrsCache.java:114)
   at org.netbeans.PackageAttrsCache.findPackageAttrs(PackageAttrsCache.java:107)
   at org.netbeans.JarClassLoader.definePackage(JarClassLoader.java:208)
   at org.netbeans.JarClassLoader.doLoadClass(JarClassLoader.java:294)
Comment 1 Petr Hejl 2014-10-10 11:21:43 UTC
Created attachment 149834 [details]
stacktrace
Comment 2 Jaroslav Tulach 2014-10-14 13:17:45 UTC
The error is here and it might be related to some other bug 247795, Tomáš was recently working on: http://hg.netbeans.org/jet-main/file/179a8aac5a0f/o.n.bootstrap/src/org/netbeans/JarClassLoader.java#l284
Comment 3 Jaroslav Tulach 2014-10-14 13:28:24 UTC
Anyway the code can be more robust:
http://hg.netbeans.org/ergonomics/rev/e7499d50abe0
Comment 4 Quality Engineering 2014-10-29 11:42:04 UTC
Integrated into 'main-silver', will be available in build *201410290913* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)

Changeset: http://hg.netbeans.org/main-silver/rev/e7499d50abe0
User: Jaroslav Tulach <jtulach@netbeans.org>
Log: #247860: More robust against NPE caused by a missing manifest