This Bugzilla instance is a read-only archive of historic NetBeans bug reports. To report a bug in NetBeans please follow the project's instructions for reporting issues.

Bug 247965 - org.netbeans.core.windows.persistence.PersistenceManager.findTopComponentDataObject: LowPerformance took 10903 ms.
Summary: org.netbeans.core.windows.persistence.PersistenceManager.findTopComponentData...
Status: RESOLVED FIXED
Alias: None
Product: platform
Classification: Unclassified
Component: Window System (show other bugs)
Version: 8.0
Hardware: All All
: P3 normal (vote)
Assignee: Stanislav Aubrecht
URL:
Keywords: PERFORMANCE
: 243759 (view as bug list)
Depends on:
Blocks:
 
Reported: 2014-10-16 06:40 UTC by Alexander Simon
Modified: 2014-11-28 07:52 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
Exception Reporter: 212762


Attachments
nps snapshot (340.28 KB, application/nps)
2014-10-16 06:40 UTC, Alexander Simon
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Alexander Simon 2014-10-16 06:40:37 UTC
This bug was originally marked as duplicate of bug 230664, that is already resolved. This bug is still valid, so this seems to be another bug, but it might be related.

Build: NetBeans IDE 8.0.1 (Build 20141008-33669bfdc920)
VM: Java HotSpot(TM) 64-Bit Server VM, 24.65-b04, Java(TM) SE Runtime Environment, 1.7.0_67-b01
OS: SunOS

User Comments:
alexvsimon: close unneded FU tabs



Maximum slowness yet reported was 10903 ms, average is 10903
Comment 1 Alexander Simon 2014-10-16 06:40:40 UTC
Created attachment 149929 [details]
nps snapshot
Comment 2 Stanislav Aubrecht 2014-10-24 13:34:49 UTC
core-main 044050709298
Comment 3 Quality Engineering 2014-10-29 11:42:25 UTC
Integrated into 'main-silver', will be available in build *201410290913* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)

Changeset: http://hg.netbeans.org/main-silver/rev/044050709298
User: S. Aubrecht <saubrecht@netbeans.org>
Log: #247965 - don't deserialize all TCs when looking for the recent one
Comment 4 Stanislav Aubrecht 2014-11-28 07:52:55 UTC
*** Bug 243759 has been marked as a duplicate of this bug. ***